Unable to install Octolapse - MemoryError

What is the problem?

Hi, I cant install Octolapse, tried so many times.
I was searching google for solutions but unfortunately with no success :frowning:

What did you already try to solve it?

  1. pip update
  2. more voltage on rpi
  3. searching for solutions

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, I cant install Octolapse in safe mode

Complete Logs


Additional information about your setup

OctoPrint 1.5.3
Python 2.7.13
OctoPi 0.16.0
Raspberry Pi 3B
10GB free on SD card in RPI

Windows 10 + Firefox or Chrome

Please help :slightly_smiling_face:

Hello @grykom !

Could it be that the SD card is quite full?

I have enought space I think


1 Like

Did you do anything from a windows machine etc.
"WARNING: Subprocess output does not appear to be encoded as UTF-8"

This is not good.

I am replying to this old topic because this is the only hit you get when you Google "Octolapse" and "WARNING: Subprocess output does not appear to be encoded as UTF-8".

I had this same issue and a fresh install of Python 3 resolved it for me. Use my steps at your own risk - I'm definitely a Raspberry Pi novice.

The steps I took were:

  • Find all installed python versions (run python --version and python3 --version)
  • Run the standard uninstall for the python versions: sudo apt-get remove pythonX.X (where X.X are the versions you found)
  • Run autoremove to get rid of any 'minimal' files: sudo apt autoremove
  • Make sure updates information is up-to-date: sudo apt-get update
  • Reinstall python: sudo apt-get install pythonX.X
  • Reinstall python dev: sudo apt-get install python3-dev (assuming you're using 3.x python)

After this I was able to install the plug-in from the plug-in manager.