Unable to Log In to OctoPrint - Forgot ID/Password

What is the problem?

Since installing OctoPrint, I have lost the ID/Password combination and cannot log in on my Mac OSX

What did you already try to solve it?

There is a link provided on the login page to "Forgot password?" - however the information on the linked page does not help me. I am not running Raspberry Pi, and I don't understand how the comments relate to my Mac OSX environment. I can't find any of the files that might relate to being able to return to "first run" to set a new ID/Password

I have tried deleting the OctoPrint directory in my area, and reinstalling. Reinstallation appears to work fine, and returns me to the login page. It does not bring me back to a "first run" condition, and so I am still stuck being unable to log in.

None of the file names indicated in the I forgot my OctoPrint password, how can I reset it? page, that apparently could return me to a "first run" condition, appear to be present on my Mac

Have you tried running in safe mode?

No - I can't see how safe mode would resolve this issue

Did running in safe mode solve the problem?

Not done

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

No OctoPi. Haven't got to the point of accessing the printer. All others are latest versions, given that I have just reinstalled OctoPrint from scratch today. Specifically MacOS Ventura 13.4

1 Like

I never used MacOS so I will take a guess (I'm also assuming that you used this guide):

  • cd into the OctoPrint folder
  • enter source venv/bin/activate
  • Run octoprint user password <user> with <user> being the name of the user for whom you want to reset the password, e.g. octoprint user password test for changing the password of the user named test. It will prompt you for a new password and then set it on the user.
1 Like

Thanks Printed. Yes, followed the guide. Could not get the Octoprint User password thing to run.

However. The key files for a return to “first run” state were in the /Library/Application Support/Octoprint/ despite a Search of the Library giving a negative result. I was able to delete users.yaml; and set first run to “true” in config.yaml using the Xcode editor to avoid scrambling the file.

Steep learning curve

Now to figure out how to use Octoprint over Wi-Fi …

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.