Unable to restart Access Control wizard (i.e. web password reset...)


#1

Starting tonight, OctoPrint stopped accepting my login credentials. I load up the local IP of the printer and am greeted with the typical login screen that also says "Site says: octoprint." But the user and pass won't take.

I then logged into the Pi via SSH with no problem. Per many sources of the same instructions, I deleted .octoprint/users.yaml and edited config.yaml so that firstRun (under server) was set to true. I then restarted the service with 'sudo service octoprint restart.'

But when I returned to the browser and tried to reload the page, I got the same login prompt. I've tried different browsers and devices, all with the same login prompt popping up.

One set of instructions said that I should also set accessControl > enabled to true, but I actually didn't have an enabled line at all. I tried adding that line with both true and false with no difference in the result. The only thing listed under accessControl is a salt string.

Finally, I also tried one user's suggestion (last post here: https://github.com/foosel/OctoPrint/issues/1063) where I used the salt from config.yaml to try and generate a new password hash with sha512, but no luck. I'm not too sure I did that right, anyway, tbh. The instructions seemed to indicate that I should put my plaintext password in front of the salt string and run that through sha512sum... is that right?

Anyway, this is with Octoprint 0.14.0. Klipper is also loaded, but I can't imagine that has anything to do with this.

My hat's off to anyone who can get me out of this mess. I'd really rather not start over from scratch :confused:


#2

OK, I feel a little bit like a tool. I just kept throwing passwords at it and it finally took one. BUT, this now indicates that I was either never going to solve my problem via Access Control because it's a different set of credentials, or...

The best I can gather, this was an account I setup when I installed OctoPrint way before I was asked to setup Access Control. Feeling a little confused...