Unable to set octoprint as a service

octoprint-systeminfo-20240101222636.zip (47.4 KB)

What is the problem?

Being unable to run the restart command in the octoprint UI I realized I missed some steps and downloaded octoprin.init, .default and .service files and placed them at the right spot. Even doing that, I am still unable to use sudo service octoprint restart because it gives me this error :

Job for octoprint.service failed because the control process exited with error code.

See "systemctl status octoprint.service" and "journalctl -xeu octoprint.service" for details.

Since I am using ubuntu server and cockpit I went and looked in the service tab where I have an error saying it failed to start with these in the service logs :

Each error has something like this

There is one thing that doesn't match and it's the path. After looking I don't have any venv folder in my Octoprint one. Instead of having Octoprint/venv/bin/... I have Octoprint/bin/...

What did you already try to solve it?

I tried following this guide : https://github.com/OctoPrint/OctoPrint/tree/master/scripts
I tried following what the guy did in this forum : Failed to restart octoprint.service: Unit octoprint.service not found - #2 by kantlivelong

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20240101222636.zip (47.4 KB)

Additional information about your setup

Octoprint Version : 1.9.3
Printer : Ender 3 V2 using Jyers firmware
Brower : Chrome
System : Ubuntu server 22.04

then adjust the path defined in the service file.

I already tried doing that but nothing changes

might be easier to start over and use the octoprint_deploy script to install. it will do all that for you.

So how do I uninstall everything?

I can only make assumptions because I don't know what all you have done, but something like this.

rm -rf ~/Octoprint
sudo systemctl disable octoprint
sudo rm /etc/systemd/system/octoprint.service