Unable to Upgrade from 1.5.2 to 1.6.1

What is the problem?

Was unable to upgrade to 1.6.1, so I reinstalled a fresh copy of OctoPi, but I am still having the upgrade fail.

What did you already try to solve it?

I updated the Firnware Check Plugin and the File Check Plugin successfully, but when I try the OctoPrint upgrade it fails.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No. Still failed.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.114 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2
printer.firmware: Marlin (Mar 18 2021

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.5.2 OctoPi version 0.18
Attaching octoprint.log and plugin_softwareupdate_console.log
plugin_softwareupdate_console.log (10.4 KB)
octoprint.log (51.9 KB)

It seems that it failed to connect to the internet to install that plugin. This is strange, since as you say the first two installed fine.

Try doing it manually from the command line:

~/oprint/bin/pip install --no-cache-dir octoprint==1.6.1

That will download it from a different place, might make a difference.

1 Like

Thanks for the advice. I'll try that this weekend.

That worked. Thanks @Charlie_Powell.

1 Like