Unable to upload gcode from PrusaSlicer

What is the problem?

I am unable to upload gcode from PrusaSlicer to Octoprint.

I get the following error message which doesnt tell me anything.

What did you already try to solve it?

  • uploading gcode to the octopi interface directly and printing works.

  • i've regenerated the application key multiple times, and even used the global key as well, i get successful "Connection to OctoPrint works correctly." message but will still get the above error message when i try to upload gcode from slicer

  • followed the help discussed in this thread to no avail Can't Connect from Slic3r Prusa Edition

  • i ran the curl check on the link above and i got the following, but don't know what to do next
    HTTP/1.1 403 FORBIDDEN
    Content-Type: application/json
    Content-Length: 135
    Cache-Control: max-age=0
    X-Clacks-Overhead: GNU Terry Pratchett
    X-Robots-Tag: noindex, nofollow, noimageindex
    X-Content-Type-Options: nosniff
    X-Frame-Options: sameorigin

{"error":"You don't have the permission to access the requested resource. It is either read-protected or not readable by the server."}

Additional information about your setup

OctoPi version 1.6.1, PrusaMini, Slic3r 2.3.1, Chrome, Win 10