Unable to use systemctl/service to start on CentOS

What is the problem?

I am trying to install octoprint on a Virtualbox running on a QNAP NAS. The Virtualbox is running CentOS 8. I have successfully installed and run octoprint via this guide: Setting up OctoPrint on a Raspberry Pi running Raspbian

It works fine but not as a background service. I run it in a terminal window that closes the server once I close the terminal. I want to enable to system service via systemctl but this fails (see below).

I have added/edited the /etc/systemd/system/octoprint.service file according to my local environment:

Description=The snappy web interface for your 3D printer

ExecStart=/home/octoprint/venv/bin/octoprint serve

# systemctl enable octoprint
Failed to enable unit: Unit file octoprint.service does not exist.

# systemctl start octoprint
Failed to start octoprint.service: Unit octoprint.service not found.

I tried to follow this guide here: https://stackoverflow.com/questions/34501611/systemd-apparently-not-finding-service-file

Which leads me to:

# systemd-analyze verify octoprint.service

which returns nothing - so I assume it's correct?

Any idea what could be wrong here?