Uncaught exception in tornado.applicaion

What is the problem?
"The OctoPrint server is currently not running"
I get this message when connecting from Chrome. I have two other tabs open to two other instances of octopi. All hardware is identical (raspi3b+ connected to the network via ethernet cable) and as far as I know, all three instances of octopi/octoprint are identical with the exception of the host names and IP addresses. This problem started out of the blue - the pi has been running fine and octoprint has been working great for months now. None of the hardware has changed, none of the network config has changed... really, nothing has changed that I know of. I tried to upload a gcode file and the upload threw an 'upload failed' error (no screenshot of this - sorry) and so I tried to restart octoprint from the drop-down menu in the top right of the browser window.

What did you already try to solve it?
When octoprint never came up after attempting to restart it, I cold booted the pi - to no effect. I ran the commands on the error screen - there is no octoprint service running. I can SSH into the pi with no problem. Octoprint Log follows...

Logs (syslog, dmesg, ...)

octoprint log:
2019-06-18 14:17:27,070 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2019-06-18 14:17:27,078 - octoprint.server - INFO - --- Log roll over detected ---------------------------------------------------
2019-06-18 14:17:27,078 - octoprint.server - INFO - OctoPrint 1.3.11
2019-06-18 14:17:27,085 - octoprint.plugin.core - INFO - 18 plugin(s) registered with the system:
| Action Command Prompt Support (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/action_command_prompt
| Announcement Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/announcements
| Anonymous Usage Tracking (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/tracking
| Application Keys Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/appkeys
| Backup & Restore (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/backup
| Core Wizard (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/corewizard
| Custom Background (0.10.1) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_custombackground
| Discovery (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/discovery
| Error Tracking (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/errortracking
| Firmware Updater (1.4.0) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_firmwareupdater
| Force Login (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/forcelogin
| Logging (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/logging
| Pi Support Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/pi_support
| Plugin Manager (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/pluginmanager
| Printer Safety Check (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/printer_safety_check
| Software Update (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate
| Themeify (1.2.0) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_themeify
| Virtual Printer (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/virtual_printer
2019-06-18 14:17:27,111 - octoprint.environment - INFO - Detected environment is Python 2.7.13 under Linux (linux2). Details:
| hardware:
| cores: 4
| freq: 1400.0
| ram: 918188032
| os:
| id: linux
| platform: linux2
| plugins:
| pi_support:
| model: Raspberry Pi 3 Model B Plus Rev 1.3
| octopi_version: 0.16.0
| python:
| pip: 19.0.1
| version: 2.7.13
| virtualenv: /home/pi/oprint
2019-06-18 14:17:27,111 - octoprint.server - INFO - ------------------------------------------------------------------------------
2019-06-18 14:32:27,074 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2019-06-18 14:47:27,077 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2019-06-18 15:02:27,078 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2019-06-18 15:14:56,366 - tornado.application - ERROR - Uncaught exception
Traceback (most recent call last):
File "/home/pi/oprint/local/lib/python2.7/site-packages/tornado/http1connection.py", line 584, in _read_fixed_body
ret = delegate.data_received(body)
File "/home/pi/oprint/local/lib/python2.7/site-packages/tornado/httpserver.py", line 311, in data_received
return self.delegate.data_received(chunk)
File "/home/pi/oprint/local/lib/python2.7/site-packages/tornado/routing.py", line 248, in data_received
return self.delegate.data_received(chunk)
File "/home/pi/oprint/local/lib/python2.7/site-packages/tornado/web.py", line 2087, in data_received
return self.handler.data_received(data)
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/server/util/tornado.py", line 268, in data_received
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/server/util/tornado.py", line 301, in _process_multipar

Thats it. That's the end of the log. I've read my share of python tracebacks and I'm pretty sure this one has been truncated for some reason, though the meat of the message is at the beginning, I suspect. I'm just not familiar with the tornado package.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Connecting to a raspi3b+ from a Windows 10 OS and Chrome browser. Hard wired network and the problem Pi is connected to the same switch it has been connected to for months along with its brothers and sisters who are working just fine.

I'm not a native Linux speaker but I can get most things done without much trouble. If there is other information that I can provide, I'll be happy to. Any assistance is greatly appreciated, and I hope that I haven't n00bed out here either with my post or my cut-rate trouble shooting skills.

On rare occasions, a RPi will corrupt its SD card. Usually this is related to power cycling without shutting down first. Since I think you said you have three systems, it sounds like musical SD cards might be a valid troubleshooting technique.

I'll give it a shot. I know I've got a few extra SD cards laying around. I really appreciate your input. I'll update after I give it a go.