Under voltage Detected after update (RESOLVED)

What is the problem?

I have a Pi 3B+ that has been running OctoPi for quite some time. It came up with an update but it would fail to install. After researching I saw it was a problem with something that came with PrintTimeGenius. I also say note about the move to Python V3. I followed the guide to backup my config then imaged my SD card with the latest release of OctoPi and imported my config on startup. Now OctoPi is constantly alerting for under voltage.

What did you already try to solve it?

I have already tried a second 2A power supply that works fine on another Pi i have.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20220801200438.zip (490.4 KB)

Hello @GForce2010 !

Power supplies can work well for a long time, but the capacitors inside get old. And so the supply can't deliver the power completely any more.

Also notice, that for a Pi 3B+, a voltage of 5.1V strongly recommended and a current of 2.5 A is needed.

I've just done some more testing.

When using the second power supply with OctoPI V17.0 there is no under voltage warning.

When using the same power supply with V18.1 I get the under voltage error.

Looks like I have a dodgy USB socket on my Pi.

I've bypassed it using my original supply and the error has disappeared.

Guess me removing the SD card tweaked it slightly causing the problem to rear it head for the first time.

1 Like