Uninstall Octoprint (not from venv)

What is the problem?

I accidentally installed octoprint and its dependencies not in a virtual environment (because copy-paste did not work properly and venv was not executed) and want to uninstall octoprint with all its dependencies. There is no requirements.txt (it's empty) and pip uninstall octoprint does not uninstall all requirements.

What did you already try to solve it?

  • pip uninstall octoprint does not uninstall the requirements
  • tried to create requirements.txt from setup.py using pipreqs, but it did not include all requirements
  • search forums but only solutions for the virtual environments are reported

Have you tried running in safe mode?

N/A

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

N/A

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

RaspberryPi 4, (pretty much stock and updated)
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

You could try using pip freeze to list everything that is installed in your environment, and then uninstall them from there. Some packages come as 'standard' though, which might be missed. It won't cause a huge problem (in terms of any conflicts with the venv) to leave them there, other than taking up some storage space. As far as I know there's no way with pip to cleanly uninstall everything that a package depended on.

Yeah, pip freeze lists also unrelated packages. I ended up removing all requirements I could find in setup.py by hand using pip uninstall xxx. I also left some packages in place that showed warnings.

It would be nice if there was a requirements list so this can be avoided.