Uninstall Octoprint

What is the problem?
I want to remove Octoprint from a Raspian install without just blowing the whole install away.

What did you already try to solve it?

I've tried quite hard to find uninstall instructions for Octoprint online and largely failed.
I tried running a command I found : "pip uninstall OctoPrint" . But this just said Octoprint was not installed ( it is - I have a process running octoprint with the 'serve' command, and I can get to an Octoprint screen via localhost:5000 ).

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
I don't think logs are going to help
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

The system is an up to date Raspian Buster on an RPi 3.

pip uninstall OctoPrint would only work if you used pip install OctoPrint to install OctoPrint in the first place. How did you install OctoPrint?

1 Like