Unstable WiFi connection

What is the problem?
Octopi on RPi 3b has strange unexplained behavior when connecting to WiFi network

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I use Wifi router to connect 1 windows PC (connected to Eth), 3 windows Laptops, 5 ios mobile phone and several home devices. I use DHCP for IP management, router IP address is
I burn octopi to 16GB sdcard using latest Pi Imager. Set octopi-wpa-supplicant.txt as per my WiFi configuration.
I use 3A mobile phone charger (PD), and connect Pi Camera. Put RPi besides my wifi router temporarily for setup.
Boot octopi, using hdmi monitor and keyb/mouse, I can see that it boots successfully.
From ifconfig, I can see that octopi receive IP from the router (, and it can ping the router (

And then some unexpected behavior observed:
*) Octopi can't ping to all laptops (using IP Address), vice versa
*) If I let octopi to keep pinging to laptop A, and laptop A to octopi, about 20-30 minutes later they can ping each other, and I can access web dashboard. But still only to Laptop A. Ping to another device result "Destination Host Unreachable" and sometimes "request time out"
*) If I use ethernet from RPi to router, this behavior is not happen. Octopi instantly able to ping to all laptops after completing boot (different IP Address). And also all laptops can access to octopi web. But this is not an option because my router is across the room from my Ender-3
*) While connected, I updated all module from octopi dashboard that need update, hope that it solve the problem, but it's not.
*) Tried to reboot or reflash sd card doesn't help.

For the reference, my router is Huawei HG8245A, which is 2.4GHz single band 802.11b/g/n

To summarizes, the ping doesn't go through to 2 windows laptops while the third laptop and the router can ping the raspi just fine over wifi. What about the phones and other devices? are they reachable?

If so it may make sense to check the firewall settings on those laptops that fail to connect.

Thanks for giving me some idea.
After doing some exhausting experiment, I came with conclusion that it might be something with security setting.
I put my wlan to WPA2 PSK - AES (it was WPA/WPA2 PSK TKIP/AES before)
Forgot wifi from all laptops, and reconfigure again. Click yes when windows want to set as Home Network.
With this configuration, all laptops can ping RPi instantly. And off course it can access octoprint web.
But still no access to all mobile phone, ios or android. Browser said could not open page because server stopped reponding / unreachable

glad to hear you got the big question answered by reconfiguring the clients.

Well, it’s not quiet there yet.
After playing with this setup for 1-2 days :

  1. No problem with pc. It can connect anytime.
  2. Laptop A lost connection after few hour. I have to forget network and configured it again.
  3. Laptop B and C permanently lost connection. Even after I reconfigured wifi connect.
  4. Mobile phone also can’t connect