Update 1.9.0 when canceling print octo won't accept a zero temperature

What is the problem?

After the 1.9.0 update, The printer reaches set temperatures (hotend and bed), and then nothing prints. The temperatures are maintained. When cancelling a print,or otherwise, Octoprint won't accept a zero temperature. So when a job is cancelled, the hotend and bed remain at the previous temperature, or when manually setting the temperature to zero.

What did you already try to solve it?

Safe mode didn't fix the problem, so it doesn't seem to be a rogue plugin.
On a second printer of the same model and settings, safemode did allow a job to be cancelled, but I didn't have the problem of a print failing to start, but i do have the "zero temperature" problem. A system reboot did not change the behaviour of the temperatures, and they remain at the previous set point.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20230601074704.zip (1.4 MB)

Additional information about your setup

, ... as much data as possible

OctoPrint version 1.9.0, OctoPi Version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2, printer Creality Ender3, firmware Marlin, browser firefox 113.0.2 (64-bit), operating system Windows 10

Hello @Blacksmithoz !

Can you please share the gcode scripts in OctoPrint?

Also please enable serial.log, try a again a print job cancelling and share the systeminfo bundle.


|  Creality Temperature (1.2.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_CrealityTemperature
|  Creality-2x-temperature-reporting-fix (0.0.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_ender3v2tempfix

Why both? They do the same.

CE3_Test Low Surface Squares pt5 PLA.gcode (38.9 KB)
octoprint-systeminfo-20230601092738.zip (132.7 KB)
Print cancel button was pressed at approx 3min after commencing print. All temps remained at setpoint.
in your BTW, I cant see the first plugin in the Plugin Manager.

Looks like you might need to do a PID tune on your printer, the temperature is oscillating quite a lot as it comes up to target so the printer never accepts another command.

1 Like

Seems it's already gone :+1:

Yes that is true, just thought I would try 1 problem at a time.

I think it's the cause of the problem you describe - if the temperature does not stabilise, the printer won't start. It also won't accept OctoPrint trying to cancel the print, which would explain why the temperature doesn't go back to zero.

I will PID tune and see how it goes

The PID autotune seems to have solved this problem.
It doesn't explain why I the job cancelling on the 2nd printer as well, as that has a very stable temperature, and I can manually change that temperature.
Thanks for your help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.