Update: Fixed! I have a new Pi 3 B+. I cannot get Octopi to do anything


NEW UPDATE: I fixed my problem. I was formatting the second drive partition when I shouldn't have been. Must have missed that in the instructions or something. Looks like everything is working, including WiFi.


I need some help here. I have a new Pi 3 B+. I cannot get Octopi to do anything.

Some history on what I have tried. I downloaded the latest build I could find for the 3 B+ and installed it on a brand new 32GB micros SD card rated as required (10). My first attempts at booting produced a Kernel fail error which I'm told is because I had the wrong partition number in my cmd file. So I changed the 2 to a 6 on the end of this entry 'root=PARTUUID=c7cb7e34-06'. That worked in that the error stopped. Now all I get on my screen is 4 raspberry icons and a cursor. I've attached a keyboard and no response to any key.

I have a power supply that came with the raspberry. If I boot it using the SD card (Noobs) that came with the raspberry, it boots fine and I can run apps and everything. What am I missing here for Octopi?

Offline (Error: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2417)
OctoPrint, OctoPi and the Raspberry Pi 3+

I'm not sure which instructions you're following but I don't remember NOOBS being involved at all. The Raspberry icons from my memory could be from the NOOBS initial boot.

My process was something like:

  1. Visit this page
  2. Download a zip file from a big green button
  3. Use Etcher to blast that image (didn't even unzip it) onto the microSD that's in my MacBook
  4. When that's finished, remove/replace the microSD because Etcher has unmounted it for you
  5. Use a text editor to edit the /boot/octopi-wpa-supplicant.txt file with my wi-fi information and making sure to include the correct country at the bottom of that file
  6. Eject the BOOT drive using the safe method on your operating system
  7. Move this to the Raspi and boot it up
  8. From your workstation, attempt to remote into it: ssh pi@octopi.local