Update from 1.3.12 to 1.5.3 Fails

What is the problem?

Update from 1.3.12 to 1.5.3 fails.

What did you already try to solve it?

Tried running in safe mode and rebooting.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

plugin_softwareupdate_console (1).log (133.8 KB) octoprint (1).log (28.2 KB)

Additional information about your setup

It's been about a year since I last used this printer and it was working well before I left.
OctoPrint version: 1.3.12, OctoPi version: 0.16, printer: Ender 3, firmware: Marlin, browser: Chrome

Try to reinstall manually. SSH to your Pi and run these commands.

sudo apt update
sudo apt upgrade
~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.5.3
sudo octoprint restart
1 Like

That worked wonders! Thanks so much!

I currently have the same issue. I've update pip and nothing. Also some plugins are not appearing. My setup is running Octodash if this would effect it.

octoprint.log (975.5 KB) plugin_softwareupdate_console.log (76.8 KB)