Update not started error

Running 1.5.1, when trying to update to 1.5.2 from update manager, I get the error:

"Update not started!
The update could not be started. Is it already active? Please consult octoprint.log for details."

I can't find anything obvious in the logs. I have restarted the rPi several times with the same issue.
I tried safe mode, with the same error

Octoprint.log here: https://pastebin.com/K8M1LeKs

You have an undervoltage problem, the power supply is not good enough. From the logs:

2020-12-18 20:38:53,618 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

Installing updates on a throttled system doesn't go well, you'll need to sort this out before you can update.

Thanks Charlie,

I will take a look at this. I was getting UI warnings when I first set it up, and swapped out the cord and charging block. Not getting the UI warnings, so I thought that was ok. I will see what I can do. Do most people run power from the printer itself to the rPi? I was looking at doing that as well as running some led lights. Cheers!

Looks like it was the cable. Working fine now. Not sure why I'm not getting undervoltage notifications in the UI anymore though (before this).

Cheers!

1 Like