Update script fails in UI due to extra "." after zip in command line

What is the problem?

The script tries to run this:

/home/pi/oprint/bin/python -m pip --disable-pip-version-check install https://github.com/OctoPrint/OctoPrint/archive/1.8.0.zip. --no-cache-dir

But I get this:

ERROR: HTTP error 404 while getting https://github.com/OctoPrint/OctoPrint/archive/1.8.0.zip.
ERROR: Could not install requirement https://github.com/OctoPrint/OctoPrint/archive/1.8.0.zip. because of HTTP error 404 Client Error: Not Found for url: https://github.com/OctoPrint/OctoPrint/archive/1.8.0.zip. for URL https://github.com/OctoPrint/OctoPrint/archive/1.8.0.zip.

What did you already try to solve it?

SSH --> CopyPaste the command above --> removing the trailing dot after zip --> Works fine

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

|  hardware:
|    cores: 4
|    freq: 1400.0
|    ram: 917016576
|  os:
|    bits: 32
|    id: linux
|    platform: linux
|  plugins:
|    pi_support:
|      model: Raspberry Pi 3 Model B Plus Rev 1.3
|      octopi_version: 0.17.0
|      throttle_state: '0x80000'
|  python:
|    pip: '22.1'
|    version: 3.7.3
|    virtualenv: /home/pi/oprint

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Have had this issue for quite some time but it's not a big issue as I work around it. Just now upgrading to 1.8 I got it (as usual) and thought I'd try to fix it or report it as a bug should it be one...

Nothing gets written to the logs

In the software update settings, you can configure the URL used to pass to pip - my suspicion is that maybe a dot has somehow made it's way there?

Indeed, thank you, thank you, thank you @Charlie_Powell :partying_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.