Update to 1.4 bricked my OctoPrint

I´ve just tried to update to the new 1.4.0 stable release and after rebooting OctoPrint just completely broke.
Absolutly no errors or hickups before that.

What is the problem?
'Loading failed' with several internal server errors in the error console, after updating to 1.4.0 via web interface and the logfile is a huge mess with many error 500 for multiple plugins

What did you already try to solve it?
Updating packages. Manual Update. Rebooting. Safe Mode. Getting angry.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
octoprint.log (111.3 KB)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
more or less OctoPrint 1.4.0, older Marlin, Chrome, Win10.

1 Like

Since you're using Chrome, can you try to go to your OctoPrint instance in incognito mode? This way you will force a refresh of the web cache.

2020-03-05 16:36:49,253 - octoprint.server - INFO - OctoPrint 1.3.12
2020-03-05 17:06:43,262 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Detecting serial port"
2020-03-05 17:06:43,287 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."

Truth is, you probably didn't visit the logs before this.

# Astroprint deprecation error
2020-03-05 17:08:41,457 - py.warnings - WARNING - /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/__init__.py:36: ExtDeprecationWarning: Importing flask.ext.login is deprecated, use flask_login instead.
  from flask.ext.login import user_logged_in, user_logged_out
# Under-voltage condition isn't caused by v1.4, I'm sure
2020-03-05 17:08:50,567 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

Indeed, you're getting several 500 errors even when you're running in safe mode.

1 Like

No change in behavior sadly.

Correct, saw no need since nothing unexpected happended prior this point. The undervoltage is reporting forever and never caused a problem (somewhere in the range of 4V85 and the Pi Spec is 4V75-5V25...), this printer is operational for more than 2 years.
The serial port detection can´t detect anything since the printer is switched by a relay and the default state is off on boot.

If it were me, I'd disconnect as many things as possible (even the printer) and start it up in Safe Mode. Do the 500 errors go away? Check the Developer's Console of your browser and look for JavaScript errors.

Disconnected everything exept power (duh.):

octoprint.log (12.1 KB)
The error 500s for several plugins are gone but /api/settings is still unhappy as soon as I try to access the webinterface.
The Console is reporting basicly the same error

There's definitely nothing in that log that indicates the issue, it ends at the same error you mentioned. I wonder if this is something related to permissions maybe. The only thing I can think of is deleting (or better yet, renaming) the configyaml file and users.yaml file and let it re-build those on initial load, like you've never set it up before. Otherwise @foosel will need to get involved.

Things we know:

  • This was an older OctoPi image @ 0.14.0
  • Python 2.7
  • A virtual environmnent where we expect it to be under ~/oprint
  • Pi3B with proper voltage when naked
  • it's having trouble serving up /api/settings (as if the ~/.octoprint/config.yaml has problems?)
cp ~/.octoprint/config.yaml ~/.octoprint/config.yaml.save
nano ~/.octoprint/config.yaml
# Look for any ugly/inconsistent formatting at the beginning of some line
# Indents should be multiples of four spaces
# top-most levels: accessControl, api, feature, plugins, printerProfiles, serial, server, temperature, terminalFilters, webcam

Made a external backup of the config and useryaml and deleted them on the pi, the result is this page on the webinterface

It´s basically an error 403 and endlessly loops on itself - so added Safe Mode again to 'kill' the plugins.
Result is the lower part (only one picture per post, yay.)

It also loops on itself - I start to think that I just should nuke the whole installation from orbit and redo everything :face_with_raised_eyebrow:

Forgot to mention it´s the same for private mode

I had a similar problem, except manual updating was a mistake, and totally bricked octoprint.
OctoPi 14
OctoPrint 1.3.12

There was no way to fix
Forced to reflash the OctoPI SD card to the latest. V17, but OctoPrint was still 1.3.12, but at least it updated automatically ok.

AstroPrint plugin is defective, likely not currently compatible with OctoPrint 1.4

Interesting. Do we have any more info on that?

Can´t confirm that. I´ve just finished freshly installing OctoPi 0.17.0 from scratch now on OctoPrint 1.4.0 and everything is working fine again, including AstroPrint.

My initial problem is basically solved by a fresh untainted installation.

Yesterday, after reflashing the SD with the latest OctoPi and followed by updating OctoPrint
First plugin to reinstall was AstroPrint. It failed to install.
Uninstalled it, and reinstall - installed successfully.
After other plugins were installed, I tried doing a print and AstroPrint plugin caused the print to fail.
I reinstalled AstroPrint again.
Finally was able to do a successful print.

I should raise a ticket about this on their github, however I was just too exhausted yesterday to get around to it.

It needs an Issue on their repository but it feels like "a ghost in the machine" so far with all these "it worked after three reinstalls" sort of comments.

another one for the list ; could anyone please post the exact commands to use over ssh (copy paste into terminal) to get the data ? mine is a rbpi w on a mk3s updated from the last stable and even after re flashing from the backup the update failed again,

I also had problems with update, till bricked. I cleared SD card and installed everything from the scratch and it's working (more-less).