Update to 1.5.3 failed spectacularly

So something weird happened while updating to 1.5.3. Instead of updating and restarting on it's own like it did on my other instances, this time it asked me to restart the instance except now the power icon was missing. So I unplugged the pi to force a reboot. When it rebooted, it said octoprint wasn't running and instructed me to ssh in and follow the instructions etc. nothing was running. sudo service octoprint start AND restart did nothing. Then it got weird. I looked for the logs but the OctoPrint directory was completely empty except for a README.txt file.

IDK WTH???

I'm totally lost on this one.

EDIT:I just tried a whereis command for Octoprint. there were no results.

What is the problem?

I tried to update to octoprint 1.5.3

What did you already try to solve it?

the ip address says octoprint not running, so I followed those ssh instructions

Have you tried running in safe mode?

can't run at all

Did running in safe mode solve the problem?

ummm

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

they don't exist anymore. Infact the OctoPrint directory is completely empty except for a README.txt from version 1.3.x

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Raspberry Pi 4B ethernet connection. That's literally it right now.

Did you look in ~/OctoPrint or did you look in ~/.octoprint? The latter is where you should be looking (and there never was a README.txt supposed to go in there.

What happens when you try to run OctoPrint manually?

~/oprint/bin/octoprint serve

@foosel I found the logs. They look completely normal except that it says I'm running 1.5.2

I'm not 100% sure what is going on here:

forgive me I'm not the best with linux stuff

Try this in SSH session to your pi...

sudo apt update
sudo apt upgrade
~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.5.3
2 Likes

the results:

It still isn't work via a browser

Ok after a couple of reboots it got weirder.
It now says I'm running 1.5.3 but the power button is missing and it keeps asking me to upgrade to 1.5.3

also there are two identical instances running off two different ips .250 and .249
one is wired and the other isn't. Same freakin' pi

power button is missing probably because the system commands got wiped out. Go into settings and look in the server section and set those and you'll get your power button back.

two ips because one wired and one wifi maybe?

yes this is exactly it.

adding the commands back fixed the power button issue. Thank you @jneilliii

fingers crossed, it all seems to be working correctly now. But wth happened?

I wasn't there so I sadly can't possibly tell you. All signs point to something got corrupted though, so best run a file system check and maybe upgrade to a new SD card just in case. These things tend to die after some while.

How do I run a file system check?
Also if I'm switching sd cards, do I just make a backup, do a fresh install, then restore from the backup?

My upgrade to 1.5.3 seemed to fail, but forcing the re-install this way helped me get back up and working. Thanks @jneilliii! Note that for it to work I needed to run all three commands recommended by @jneilliii:

sudo apt update
sudo apt upgrade
~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.5.3

This just saved mine - same scenario upgraded - enver came back up - nothing in logs beyond the upgrade - no response to python running or reboot - thought it was bricked - took a while but this got it going again! Thank you!