Update to 1.5.3 failed

What is the problem?

Receive "Update failed! The update did not finish successfully. Please consult . . . logs for details", when trying to update to version 1.5.3

What did you already try to solve it?

Repeated attempts to install, reviewed logs, but nothing helped.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

plugin_softwareupdate_console.log (280.8 KB)
serial.log (148 Bytes)
octoprint.log (132.6 KB)
Terminal.log (2.9 KB)

Additional information about your setup

OctoPrint version 1.3.8, OctoPi version 0.15.1, printer Geeetech A10, Marlin 1.1.8, Board GT
2560 v3.0, browser MS Edge, operating system Win10 up-to-date
plugin_softwareupdate_console.log (280.8 KB)

You could try to reinstall manually. SSH to your Pi and run these commands.

sudo apt update
sudo apt upgrade
~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.5.3
sudo service octoprint restart

Thanks for you rapid response for help! I was unable to try your fix until this morning. It worked!

I did have to add “service” after sudo” to your last line of code to complete the restart.

Thanks again for all your help!

See ya!



“Try to be as good as your dog thinks you are.”


Thanks, I have updated the commands. Please make sure to Mark the Solution in case others find this in search.

This did the trick for me now as well. Thanks!

For anyone else who might find this, I needed to do an intermediate update of pip for this solution to work for me. Thus, the following command sequence got it done:

sudo apt update
sudo apt upgrade -y
~/oprint/bin/pip install --upgrade pip
~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.6.0
sudo service octoprint restart

Good luck!

1 Like