Update to 1.7.2 from 1.6.1

What is the problem?

I can not update from 1.6.1.

What did you already try to solve it?

do that:

~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.6.1

but with this error:

ERROR: Command errored out with exit status 1:
   command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmp5QxY4Z
       cwd: /tmp/pip-install-wMJRtY/pyyaml
  Complete output (4 lines):
  Traceback (most recent call last):
    File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py", line 15, in <module>
      from glob import glob
  ImportError: No module named glob

ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmp5QxY4Z Check the logs for full command output.

Have you tried running in safe mode?

I don't know how to do that.

Did running in safe mode solve the problem?

I don't know how to do that.

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Safari/605.1.15
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: false
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 904245248
env.os.bits: 32
env.os.id: linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.13.0
env.python.pip: 20.3.4
env.python.version: 2.7.9
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Additional information about your setup

OctoPi version: 1.6.1
, printer: ender3
, firmware: custom marlin
, browser:safari
, operating system: OS X

LOG

2021-11-04 20:02:54,613   /home/pi/oprint/bin/python2 -m pip --disable-pip-version-check install https://github.com/OctoPrint/OctoPrint/archive/1.7.2.zip --no-cache-dir
2021-11-04 20:02:57,656 > Collecting https://github.com/OctoPrint/OctoPrint/archive/1.7.2.zip
2021-11-04 20:02:58,659 > Downloading https://github.com/OctoPrint/OctoPrint/archive/1.7.2.zip (6.6 MB)
2021-11-04 20:03:07,258 > Requirement already satisfied: OctoPrint-FileCheck>=2021.2.23 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (2021.2.23)
2021-11-04 20:03:07,259 > Collecting OctoPrint-FirmwareCheck>=2021.10.11
2021-11-04 20:03:07,259 > Downloading OctoPrint_FirmwareCheck-2021.10.11-py2.py3-none-any.whl (33 kB)
2021-11-04 20:03:07,260 > Requirement already satisfied: OctoPrint-PiSupport>=2021.10.28 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (2021.10.28)
2021-11-04 20:03:07,260 > Requirement already satisfied: markupsafe<2.0,>=1.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (1.1.1)
2021-11-04 20:03:07,260 > Requirement already satisfied: markdown<3.2,>=3.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (3.1.1)
2021-11-04 20:03:07,261 > Requirement already satisfied: regex!=2018.11.6 in /home/pi/oprint/lib/python2.7/site-packages/regex-2016.04.15-py2.7-linux-armv7l.egg (from OctoPrint==1.7.2) (2016.4.15)
2021-11-04 20:03:07,263 > Requirement already satisfied: wrapt<1.13,>=1.12.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (1.12.1)
2021-11-04 20:03:07,264 > Collecting flask<2,>=1.1.4
2021-11-04 20:03:07,264 > Downloading Flask-1.1.4-py2.py3-none-any.whl (94 kB)
2021-11-04 20:03:07,265 > Collecting Jinja2<3,>=2.11.3
2021-11-04 20:03:07,265 > Downloading Jinja2-2.11.3-py2.py3-none-any.whl (125 kB)
2021-11-04 20:03:07,266 > Requirement already satisfied: Flask-Login<0.6,>=0.5 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (0.5.0)
2021-11-04 20:03:07,266 > Requirement already satisfied: Flask-Babel<2,>=1.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (1.0.0)
2021-11-04 20:03:07,267 > Requirement already satisfied: Flask-Assets<3,>=2.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (2.0)
2021-11-04 20:03:07,267 > Requirement already satisfied: werkzeug<2,>=1.0.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (1.0.1)
2021-11-04 20:03:07,268 > Requirement already satisfied: itsdangerous<2,>=1.1.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (1.1.0)
2021-11-04 20:03:07,268 > Requirement already satisfied: cachelib<0.2,>=0.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.2) (0.1)
2021-11-04 20:03:08,273 > Collecting PyYAML<6,>=5.4.1
2021-11-04 20:03:08,273 > Downloading PyYAML-5.4.1.tar.gz (175 kB)
2021-11-04 20:03:09,276 > Installing build dependencies: started
2021-11-04 20:03:26,870 > Installing build dependencies: finished with status 'done'
2021-11-04 20:03:26,871 > Getting requirements to build wheel: started
2021-11-04 20:03:26,871 > Getting requirements to build wheel: finished with status 'error'
2021-11-04 20:03:26,874 ! ERROR: Command errored out with exit status 1:
2021-11-04 20:03:26,875 ! command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmp3Lrds2
2021-11-04 20:03:26,875 ! cwd: /tmp/pip-install-AKRLTf/pyyaml
2021-11-04 20:03:26,875 ! Complete output (4 lines):
2021-11-04 20:03:26,876 ! Traceback (most recent call last):
2021-11-04 20:03:26,876 ! File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py", line 15, in <module>
2021-11-04 20:03:26,879 ! from glob import glob
2021-11-04 20:03:26,879 ! ImportError: No module named glob
2021-11-04 20:03:26,880 ! ----------------------------------------
2021-11-04 20:03:26,880 ! ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmp3Lrds2 Check the logs for full command output.

Hello @AnakinO7 !

You are running still OctoPi 0.13.0.

It's strongly recommended to upgrade to OctoPi 0.18.0

You can backup your settings and the installed plugins and restore them within the setup wizard of the new install.

You can find the backup feature in the OctoPrint settings

OctoPi 0.13 is over 5 years old now - the Python environment on that image is outdated and no longer supported.

I'm surprised you managed to install 1.6.x to be honest!

At least you know you are quite unique - the usage tracking says there's 23 OctoPi 0.13 instances out of ~113k tracked instances.

3 Likes

I must also be one of those 23 OctoPi 0.13 instances in your stats. About box says: "Version 0.13.0, running on Raspberry Pi 2 Model B Rev 1.1" ... I encountered the same issue updating from 1.6.1 to 1.7.2 this past weekend, which led me to this discussion. I guess it's time for me to upgrade too :slight_smile:

I could probably smash-and-bash a new Python env on there and get it going again, but I could probably use a new Debian too... Jessie is a bit long toothed as well.

I wonder how much longer it will take until the other 21 users of OctoPi 0.13 show up to this discussion. LOL

2 Likes

I just created a new account to tell y'all that I also use 0.13.0. Haha.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.