Update Unable to Complete

What is the problem?

My octoprint will not update

What did you already try to solve it?

I have tried freeing up space on my pc and re running the install

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

It gives me an error every time I try to do this heres a copy
browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Additional information about your setup

ender 3 v2, octoprint version

these are the updates I am trying to complete

When I do try to update it this is the error I get for each part
ERROR: Exception:
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 224, in _main
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/cli/req_command.py", line 180, in wrapper
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 280, in run
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/cache.py", line 293, in init
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/cache.py", line 262, in init
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/utils/temp_dir.py", line 141, in init
File "/home/pi/oprint/lib/python3.7/site-packages/pip/_internal/utils/temp_dir.py", line 189, in _create
File "/home/pi/oprint/lib/python3.7/tempfile.py", line 495, in mkdtemp
File "/home/pi/oprint/lib/python3.7/tempfile.py", line 265, in _sanitize_params
File "/home/pi/oprint/lib/python3.7/tempfile.py", line 433, in gettempdir
File "/home/pi/oprint/lib/python3.7/tempfile.py", line 368, in _get_default_tempdir
FileNotFoundError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']


that sounds pretty basic:

no usable temp space? Is there any space left on your sd-card at all?
The first thing I'd do confronted with such a message is:

  • ssh into the pi
  • df -h

Please do and post the output.

1 Like

Okay, so I do not know how to ssh into a pi but also, it seems to have fixed itself? I'm not really sure what happened or why but thank you for trying to help.

You may have had some random OS issues (can happen with the WiFi drivers) where it fills up the log files with errors - after some time these files are compressed and rotated so you might find it automatically freed that space.