**UPDATED** OctoPi (still) not connecting on Computer

Hi community, I'd love some help completing setup! I'm fairly certain its an easy fix for experienced folks, but i'm relatively new to Raspberry Pi and worry its user error :unamused:

We have added a Prusa MK3S MMU to our model shop at the office, with OctoPi & webcam.

When trying to connect from my desktop, it always returns Offline (Error: Could not write to serial port).

This made me think something was fundamentally wrong with my setup, but if I open the OctoPod app on my phone I can see the webcam feed (when on the office WiFi -- doesn't work offsite) but have no controls. This make me think something is correct.

To try and fix it, I've...

  1. surfed through a ton of the forum posts to no avail, followed one by @b-morgan and used it as my main guide
  2. (obviously) tons of googling
  3. tried every option under the Serial port dropdown (Auto and '/dev/ttyAMA0')
  4. tried every baudrate option in the dropdown
  5. updated to OctoPrint 1.4.2
  6. stumbled through the settings while keeping my fingers crossed
  7. saw a post where @foosel suggested checking the box on Serial Logging. When I did this and tried to connect, it returned a new error Offline (Error: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2916)

In the hopes of reversing the curse that is 2020, I've uploaded Octoprint.log.

my OS is Windows 10, OctoPrint 1.4.2, printer is Prusa MK3S MMU, Prusa firmware is 3.9.0, browser is Google Chrome, running on a Raspberry Pi Zero W connected to one of the office Wifi networks, and it's partly cloudy here is Texas (don't think that matters, but still...)

octoprint.log (33.9 KB)
serial.log (2.9 KB)


I attempted to start fresh based on some ideas and suggestions I've seen elsewhere through this great community.... and I mean start REAL fresh! New Pi, new flash of OctoPi, everything. same freakin result.

I am utterly and completely stuck! Please Octoprint community, save me from this black hole.

This could be part of the issue: The Pi zero is severely under powered for OctoPrint. On the download page:

Raspberry Pi 3B, 3B+ or 4B 1/2/4GB strongly recommended, Raspberry Pi Zero/Zero W not recommended at all!

How is the printer connected to the Pi? And what OctoPi version have you used?

For further clarification:
  • You'll likely see that you can get the webcam too, from OctoPrint's web interface. It's the serial connection to the printer you're having issues with
  • As long as it's not raining on the printer :slight_smile:

Appreciate the post @Charlie_Powell. I knew the Pi W was a bit on weak side, but had a few on hand and opted to give it a try. I stumbled across OctoPrint from YouTuber Chris' Basement and was surprised that he went with a Pi W after reading the specs you referenced (https://www.youtube.com/watch?v=mnN4HVmjafs&list=PLEf1uiAUbsfsgFhPUymUBgK1RZirM_ZwX&index=8&t=572s). Anyways, I knew it was a gamble but went with it.

I had one version connected directly to the Einsy board (sim to the linked video). Ideally, this is the way I'd like to go but continue to have trouble. But in the interest of narrowing down the issues, I loaded my last Pi W and connected it through the USB-B port. This one came to life and worked fine :exclamation:

So not ideal, but if (when really, no if) I config the user interface to ensure everything is working I'll likely just try to design/print an enclosure and add this to the printer frame. I'm still curious why the first Pi isn't working like the second, but at this point beggers can't be choosers.

:exclamation: - since the Pi W only has two microUSB ports, I cannot plug in either the Logitech webcam or the borescope cam at the hotend since this options requires external power. Not a deal breaker, and compared to no OctoPi it's worth sacrificing... for now, whenever I exchange the Pi I'll work to resolve it.

Hold on!!!! Wait a damn minute @Charlie_Powell... are you implying that my idea for an exterior model shop next to a swimming pool, high humidity, and a mister positioned neatly in a rainforest IS NOT a good idea?!

Geez... way to burst my bubble.

Just for clarification, can I still have a water balloon fight with my printer?

I think there is some extra config needed in the OS for it to connect via GPIO pins, so make sure you have done that. Not entirely sure what is necessary but there is some enabling of interfaces needed. Not familiar with this process though, so can't help on that.

It's easy for a Pi to go wrong, especially the zero - they skipped some of the protection to make it so small & cheap.

My recommendation is a Pi 3B+ or a Pi 4 (2GB RAM), whichever is cheaper should you choose you choose to get a different Pi.

This made me smile, have fun :upside_down_face: