Updated OctoPrint - now it won't run at all!

What is the problem?

the service apparently is not running as I get that page
I had just upgraded octoprint and octotext

What did you already try to solve it?

rebooted with power
I removed all periprials, USB keyboard, the printer, the camera
(tried another board, but I think that board is bad.)
SSH - found that octoText kept on crashing in octoprint.log (see below)
tried to pip uninstall octotext but then pip crashed with a no space left error
so i went around and rm'd some mp4s and went back, pip still exceptions
then i got mad and rm'd octotext
confirmed it was dead with trying to pip uninstall it and it said not installed
rebooted via power
still complains service not running
Oh yeah - `ps -ef | grep -i octoprint | grep -i python does not seem to do anything, no error, just returns my command line. But just ps shows itself and bash running, no octoprint instance.

See below for what i saw on loging in via ssh - it seems to think that octoprint IS running!

ssh shows this on login:

Access OctoPrint from a web browser on your network by navigating to any of:


https is also available, with a self-signed certificate.

This image comes without a desktop environment installed because it's not
required for running OctoPrint. If you want a desktop environment you can
install it via

sudo /home/pi/scripts/install-desktop

OctoPrint version : 1.8.0
OctoPi version : 0.18.0

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Well tell me how to get to it via SSH... i got some of octoprint.log ... it seemed to be happening every 500ms, that;s why i went to uninstall, then deleted it. OP isn't logging anything new now.
2022-05-19 02:27:53,462 - octoprint.environment - INFO - Detected environment is Python 3.7.3 under Linux (linux). Details:
| hardware:
| cores: 4
| freq: 1500.0
| ram: 1903988736
| os:
| bits: 32
| id: linux
| platform: linux
| plugins:
| pi_support:
| model: Raspberry Pi 4 Model B Rev 1.4
| octopi_version: 0.18.0
| throttle_state: '0x0'
| python:
| pip: 20.3.3
| version: 3.7.3
| virtualenv: /home/pi/oprint
2022-05-20 02:51:08,452 - octoprint.plugins.OctoText - ERROR - Exception while talking to your mail server [Errno -3] Temporary failure in name resolution
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_OctoText/init.py", line 258, in smtp_login_server
SMTP_server = smtplib.SMTP(name, port, timeout=5)
File "/usr/lib/python3.7/smtplib.py", line 251, in init
(code, msg) = self.connect(host, port)
File "/usr/lib/python3.7/smtplib.py", line 336, in connect
self.sock = self._get_socket(host, port, self.timeout)
File "/usr/lib/python3.7/smtplib.py", line 307, in _get_socket
File "/usr/lib/python3.7/socket.py", line 707, in create_connection
for res in getaddrinfo(host, port, 0, SOCK_STREAM):
File "/usr/lib/python3.7/socket.py", line 748, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Temporary failure in name resolution
2022-05-20 02:51:34,184 - octoprint.plugins.usb_keyboard - DEBUG - Found printer commands for key 'f4'. Sending '['M117 Normal Speed', 'M220 S100']'
2022-05-20 02:52:34,546 - octoprint.plugins.OctoText - ERROR - Exception while talking to your mail server [Errno -3] Temporary failure in name resolution
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_OctoText/init.py", line 258, in smtp_login_serv


Additional information about your setup

I just had upgraded to the new OctoPrint and also upgraded octotext - i fired off one print and sometime after finishing it died.


SOLVED - I found out thru df that the root mount was full and then found the upload directory and rm -R'd that dir, to be nice i remade it, emtpy. Now it runs, now i can sleep.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.