Updated to python 3.7.3

Update Available

There are updates available for the following components:

This version of the Python environment is not supported for direct updates.

Since upgrading to python 3.7.3 I cannot install plugin updates
Regards Troysie

  • OctoPrint 1.7.0
  • Python 3.7.3
  • OctoPi 0.17.0

Either SSH into your pi and

~/oprint/bin/pip install -U pip

or alternatively make sure this checkbox is selected and then save:

Actually, never mind, just saw you are already on 3.7.3.

In that case, a systeminfo bundle please, we can't help you without one.

The updating pip solution is still the most likely I would say.

octoprint-systeminfo-20211103073328.zip (122.7 KB)
System info attached.
Thank you

I have enabled pip through the tick box, but still same error
Regards Troysie

It's an outdated pip, but that's probably also preventing the update through the UI from going through.

Do the command line update steps outlined above:

Restart and it should work.



Your Pi is soft throttled due to overheating, you need to fix its cooling situation.

Finally, if you'd shared a screenshot of the mysterious error you are getting and the bundle from the get go, this would have gone much faster :wink:

I have updated pip which seems to have sorted the python error, but as you can see on the screen shot it still will not automatically update, also I have noticed there is a warning triangle on each plugin. When I scroll down the warning triangle is on every plugin. This is not stopping the Octoprint and the printer from working perfectly. I checked the Pi temperature over a 45min print and it reached 60.1 degrees, it would possibly go higher on a long print, so I am going to install a cooling fan.
Thank you for your ongoing help
Regards Troysie

Does it make a difference if you select 'advanced options' and then force-check? Or changing some of the release channels to try and see if that prompts it to refresh and update. Assuming you already tried restarting OctoPrint/rebooting etc.

Still will not install updates automatically.
Can I install these updates manually and if so how.

This morning the option appeared to install 1.7.2. I installed this and after that everything else followed on and all updates installed. All is now working fine. Thank you for all your help.
Regards Troysie


Hello, had exactly the same problem, old python, unable to update octopi. Updated python, still couldn't update system.
The issue was resolved after that I increased the "minimum disk space", in software update -> plugin configuration.
Just reporting in case someone stumbles into this...

Still can't update Arc Welder but heh, will check into it when time allows...

Arc welder is a problem with the plugin's update configuration. There's a pre-release version you can install directly from GitHub, that fixes the issue but no stable release yet.

Thanks man, I will check into it!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.