Updating process on the stock S1 Pro display

What is the problem?

Cannot get the stock Ender 3 S1 Pro display to update the progress during a OctoPrint print session.

What did you already try to solve it?

Install DisplayLayerProgress plugin, but this didn't work (also seems to be for the standard Ender 3).
Tried sending M73 GCODE, but got a "unknown command" reply.
Tried sending M117 GCODE, but nothing happens.
Tried googling for solutions, but to no avail.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

I guess not.

Systeminfo Bundle

connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1000.0
env.hardware.ram: 380948480
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi Zero 2 W Rev 1.0
env.plugins.pi_support.octopi_camera_stack: webcamd
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.2-20230718111854
env.plugins.pi_support.octopiuptodate_build_short: 2023.07.18.111854
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: 2024-04-13T18:33:48Z
octoprint.last_safe_mode.reason: incomplete_startup
octoprint.safe_mode: False
octoprint.version: 1.9.3
printer.firmware: Marlin (Jun 13 2022 09:27:38)
systeminfo.generated: 2024-04-20T20:47:19Z
systeminfo.generator: zipapi


Additional information about your setup

Printer is a Ender 3 S1 Pro with the F301 board, running stock firmware.
If there is no way to fix it with GCODE commands or a OctoPrint plugin, I am open to compiling a custom firmware.
Ideally I'd like to update Marlin version and enable certain features, but still be able to use e.g. the stock display and SD card (I am working remotely and in my workshop sometimes).
I didn't really look into this yet, because I am a bit afraid to brick the printer and I need it a lot these days.

The standard command for controlling the printer's progress bar, from a host like OctoPrint, is the M73 command you already tried. The fact that this responded "unknown command" suggests to me that the firmware on your printer does not support this feature.

Not sure about the M117 commands - that would not update the progress bar, but might show whatever text you sent on the screen somewhere. Again you've used the right commands, so maybe it isn't supported.

By compiling your own firmware you would be able to enable these features, hopefully. I don't know exactly how the screen/firmware works on this printer - there are some that run their own firmware, especially the touchscreens and it gets complicated. I'd recommend consulting the Marlin firmware community on this one - they have a discord server that has many people knowledgeable and helpful.