Updating to 1.7.3 isn't working

What is the problem?

When I go to update OP (OctoPrint). it says it's updating, says successful, but it stays in the same version

What did you already try to solve it?

I tried to run an update in the terminal using this code

pip install octoprint==1.7.3

I tried simply clicking the update button

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

I can't get the Systeminfo bundle, as my version doesn't support it.

Additional information about your setup

I used an hp desktop running Ubuntu, I use an Ender 3 V2, and I used firefox to open the UI.

Did you activate your virtual environment before running this command?

What errors do you get when pressing 'update'? Instead of the systeminfo bundle, the octoprint.log and the plugin_softwareupdate_console.log files from OctoPrint's logging section would be useful.

octoprint.log (13.3 KB)
Tried with venv, no change. and I cant attach plugin_software_console.log files, it says its empty

Ok well here is your problem. You have installed OctoPrint using snap, which is not a supported method of installing it. We don't know who has published the octoprint-pfs snap distribution, but I know it has problems, especially with updating and connecting to printers. As you found out, it is also nearly 2 years outdated (with 1.4.0 not 1.7.x).

Uninstall the snap version of OctoPrint and then complete the setup guide on the forum, which should get you up and running with the latest version, working properly. Just substitute your username wherever pi is mentioned.

1 Like

Is there a terminal command to delete op off of snap?

Presumably you can uninstall it the same way you installed it, through Snap.

How to uninstall snap ubuntu

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.