Upgrade process glacially slow at zeroconf stage

What is the problem?

Hi all,

I'm new to 3D printing, and just acquired a ~10 year old MakerBot. I decided to give OctoPi a try, since it predates networking. When OctoPrint tries to update, the system hangs forever, though it has not crashed. I'd imagine it is working, just at a ridiculously slow speed.

Is there a fix or workaround? And is this something I'm going to have to be concerned about happening every time there is an update?


What did you already try to solve it?

Everything is fine with flashing a memory card and booting it up on a Raspberry Pi Zero 2W. I can connect to the OctoPrint web interface for the initial setup. It offered to run an update on OctoPrint, which I accepted, and then the system ground to a halt. I was able to ping it from my network and I could switch to another TTY, so I know it hadn't crashed. I left it sitting like that for hours.

I gave up and tried flashing another memory card, but this time, I opened a second TTY with "top" running, and I ran the update on the first TTY (~/oprint/bin/pip install -U octoprint). It got to the step in the upgrade process where it was upgrading zeroconf. When I check "top", kswapd0 is running at 100% CPU and my load average is over 24. Currently it has been 25 hours in this state. Even top is only updating once every 6 hours or so!

I did also try flashing another memory card and doing the upgrade on a Raspberry Pi 4. It did hang at the zeroconf stage, but got through pretty quickly. However, putting that memory card into my Zero 2W afterwards caused different issues (it would only show stuff on the screen during boot and shutdown; otherwise just a black screen). (Even solving this problem would be sufficient!)

Have you tried running in safe mode?

I don't think that applies here as the problem isn't in the OctoPrint application itself, but the upgrade process.

Did running in safe mode solve the problem?


Systeminfo Bundle

Can't get in to generate a bundle.

Additional information about your setup

Octopi 1.0.0: OctoPrint 1.8.6 running on Raspberry Pi OS Debian Bullseye 2022-09-22. Raspberry Pi Zero 2W. No printer hooked up yet. Running the upgrade through the local CLI, not over SSH and not a browser.

This was mentioned in the release notes. Make sure your pip in OctoPrint's virtual environment is up to date.

Hi jneilliii,

I updated pip to version 24 before my most recent attempt, which is going on 30 hours now...