Upgrade to 1.9.0 restore from backup

What is the problem?

Upgraded a fresh install to OctoPrint 1.9RC6 yesterday and restored a backup from another install. I uploaded a gcode from PrusaSlicer and I see "Model contains no extrusion.".
When I look at the log for PrintTimeGenuis, it is still looking for python3.7 when it is now running 3.9.
Exception: /home/pi/oprint/bin/python3: can't open file '/home/pi/oprint/lib/python3.7/site-packages/octoprint_PrintTimeGenius/analyzers/analyze_gcode_comments.py': [Errno 2] No such file or directory

What did you already try to solve it?

I've changed
"/home/pi/oprint/bin/python3" "/home/pi/oprint/lib/python3.7/site-packages/octoprint_PrintTimeGenius/analyzers/analyze_progress.py" marlin-calc "{gcode}" "{mcodes}"
"/home/pi/oprint/bin/python3" "/home/pi/oprint/lib/python3.9/site-packages/octoprint_PrintTimeGenius/analyzers/analyze_progress.py" marlin-calc "{gcode}" "{mcodes}"
In PrintTimeGenius settings, won't know if this has worked until it has stopped printing.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Don't know.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.9.0RC6, OctoPi 1.0.0.
octoprint-systeminfo-20230515181223.zip (102.5 KB)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.