Upgraded from 1.8.1 to 1.8.4 and cannot logon to web interface

What is the problem?

Upgraded from 1.8.1 to 1.8.4 and cannot logon to web interface

What did you already try to solve it?

Tried resetting user password and it doesn't work

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Cannot get systeminfo bundle since I cannot logon, tried via SSH and cannot get it either, I do the command and no optput.


Additional information about your setup

OctoPrint 1.84, RaspOS - Linux 3dpi 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l GNU/Linux (not running octopi), Tried mulitple broswers doesn't matter

Pretty frustrating, needing to print some things and cannot login to push the jobs, looking at the journalctl evrything appears to start properly but not able to logon now, thinking of downgrading back to 1.8.1 since it was working there, not sure what broke but maybe the argon stuff.

Looks like HAproxy issue which I forgot that I was even using. This is a manual install following the guide, had been working fine until upgraded to 1.8.4.

Here is my install information:
pip -V
pip 21.1.2 from /home/bishop/OctoPrint/venv/lib/python3.7/site-packages/pip (python 3.7)
(venv) bishop@3dpi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"
SUPPORT_URL="RaspbianForums - Raspbian"
BUG_REPORT_URL="RaspbianBugs - Raspbian"

Here is what fixed it for me updating HAproxy.cfg and including the following:
option forwardfor
http-request set-header X-Real-IP %[src]
http-request set-header X-Forwarded-Proto https if { ssl_fc }

I assume other manual installs using HAproxy will stop working until the HAproxy configuration has been updated.

Please compare your configuration to the configuration examples to ensure that you have all the sections that are required to avoid stuff breaking.

Thanks for the reply but maybe I am missing something but on a manual install following the user guide (been operational for sometime) upgrading to 1.8.3-4 broke the standard HAproxy configuration. based on the guide that you have listed there is what I had and it did not work, I saw in one of the many web password threads that unless I added these following lines:

 http-request set-header X-Real-IP %[src]
 http-request set-header X-Forwarded-Proto https if { ssl_fc }

reqadd X-Scheme:\ https if { ssl_fc }

either one of those added to the HAproxy.cfg and it worked again, so something changed in operation when I upgraded and it broke HAproxy. It's been so long since I set things up I had forgotten that I even was using HAproxy. This was a manual install and it works fines and has updated everytime but this latest time, just wish there had been some notification about updating your HAproxy.cfg to fix correct the logon issue. But it is working now but I assume there will be others when they upgrade that will brake them...

Thanks for the reply. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.