Upgraded to 1.8.3 and logins stopped working

No, don't work either. Same Issue.

Can somebody give me a hint how to rollback to 1.8.2. on my ubuntu installation ? I did

source /home/octoprint/python_venvs/octoprint2/bin/activate
pip install https://github.com/foosel/OctoPrint/archive/1.8.2.zip

but afterwards the service do not start

pkg_resources.DistributionNotFound: The 'OctoPrint==1.8.2' distribution was not found and is required by the application

Rollback instructions are here: How do I roll back from 1.8.3+ to a version prior without losing the ability to login?

1 Like

With what guide did you install OctoPrint on Ubuntu?

I used this one and there have been no update issues.

I followed that one:

but one of my 3 octoprint instances are broken now...

If you're using virtual environments (venv), are you sure you installed argon2_cffi into the same virtual environment? What happens if you run Octoprint server via the CLI (octoprint serve -v) instead of the daemon?

Are you using a reverse proxy in front of Octoprint?

I have HAProxy in front of my Octoprint instance and had to add

        option forwardfor
        http-request set-header X-Real-IP %[src]
        http-request set-header X-Forwarded-Proto https if { ssl_fc }

in order to log in.

1 Like


argon2_cffi pip binary is ducked. just do a:
pip install --force-reinstall --no-binary :all: argon2_cffi

No luck running that force no-binary all command on raspberry....

  Collecting importlib-metadata
    Downloading importlib_metadata-4.12.0.tar.gz (48 kB)
       ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 48.2/48.2 kB 1.2 MB/s eta 0:00:00
    Installing build dependencies: started
    Installing build dependencies: still running...
    Installing build dependencies: still running...
    Installing build dependencies: finished with status 'error'
    error: subprocess-exited-with-error

Managed to fix it on raspberry by installing with following command in venv:

pip install --force-reinstall --no-binary=argon2-cffi-bindings argon2_cffi

And by adding haproxy forwardfor rules also the remote access now works.

And same fix also worked for my pine64 venv env.

This did not work for me on 1.8.4

I am DIW also since 1.8.3 or 4
no password or name is valid. 3 instances on 2 rock64's are now DIW, Cant''t login to the web page at localhost:5000, or from another machine at rock64:5000 both of which worked with 1.8.2.

And as an additional seemingly unrelated, clue cura 5.2.0 beta for linux is crashing at the file save after a simple .stl is sliced. AND restoring to 5.1.0 which has been working well, but now 5.1.0 is also locking
up, responding only to a ctl+c from the terminal that started it. The save to disk bar changes color
slightly when clicked on after the slice, and its DIW until the terminal that started it gets a ctl+c.

So my theory is that some other library it uses, has been updated, and broke both cura and octoprint in the last 3-5 days.
cura is normally ran on this machine, and the gcode is then saved over my local network directly to the "watched" directory on which ever printer I'm feeding.

unforch, argon2_cffi is not know to armbian 11's apt. And it says this topic has been solved, but I don't
see the solution?

turns out to be a pip responsibility, put that in my install script and now I can login again. I wonder if that's the same problem with cura? Back to the drawing board I think.

maybe you forgot to update haproxy settings too, as you only pasted pip on your reply. Or maybe you should try to downgrade to 1.8.3 and apply fix before going to 1.8.4. Or paste the error message on pip install. But that pip force reinstall has worked for others (make sure that you have activated venv before runnin pip). Or paste the error message when you use command line to set the password (octoprint user password admin).

@WOWElectronics, Cura and OctoPrint are installed & run very differently, so they won't have a common problem or common solution unfortunately.

The solution to this topic is marked, the below post:


I started by doing this.

this is the link that appears on the Login Screen when we have problems. this is the first not been able to print stuff. I could not solve the issue yet.

Yeah, that solved the issue. I did not remember I was using haproxy. It was missing that part.

But the procedure on the Reset Passwords fucked up my whole setup. This is crazy.

The button to finish the Wizzard is not working too. I cannot leave this screen

EDIT: oh boy, it just took a lot of time without any info. it i ok. thanks for the support.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.