Upgrading Octoprint when installed with snap

What is the problem?

I installed octoprint using snap and I added the --devmode command at the end of the install because it wouldnt connect to the usb ports . Now that is working but trying to update it will not work
When I try to upgrade on the web portal it opens a window stating update completed and it doesnt update.

What did you already try to solve it?

I have tried to find where it is installed at and I cant find it. I am using the latest ubuntu on a old hp pavilion g6 laptop. I am new to lynx so some features are new to me. I do have the latest python3 installed.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Snap is not a supported method of installing OctoPrint. We have no idea who published the snap version and it doesn't work properly. You are best off installing OctoPrint using the official guides. It may be more work, but at least it works properly.

You can use this guide:

Just substitute your username wherever the guide uses pi.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.