Upload Configuration.h to Raspberry Pi

How do I upload a Marlin Configuration file from Windows 10 Microsoft VSC running Marlin to a Raspberry Pi B v3 running 'OctoPi'.

Pi is connected to RAMPS 1.4 EFB mounted on an Arduino Mega 2560.

Previous to the 'OctoPi' configuration I have been using 'Pronterface' on the PC connected to the RAMPS 1.4 EFB via it's USB input on COM14 allowing uploads to the Arduino. 'OctoPrint' only sees the //tty/ COM port for serial connectivity.

The file configuration.h is part of the Marlin firmware package and is needed for the compilation of the firmware.

So, what is the need to upload configuration.h to OctoPi?

I may not have made myself clear and you are correct - there is no need to upload it to OctoPi.

I wish to upload it to the Arduino so I guess this does not make it an 'OctoPrint' issue but I would appreciate your confirmation.

After further reconsideration I now think that the only way is to physically switch the USB connection (i.e. disconnect cable from Pi to RAMPS and connect Desktop PC to RAMPS each time I wish to make a change to the Config file)? Was it that obvious? - sorry.

So you want to upload the configuration.h to the printer board?

Usually when you make changes to the configuration.h you have to recompile Marlin.
The result is a *.hex that is "burned" to the printer boards EPROM.

There is also the firmware update plugin. If you compile to the hex binary, you can then upload it through there. Configuration.h doesn't go near the printer, it must be compiled first.

That is just what I needed. Thanks Charlie.

I had seen the plugin before I started using the RAMPS controller board and VSC but was not sure what it did or how to use it.

Having now installed "avrdude" on the Pi it now "flashes" perfectly.

I needed to change a couple of things in the Firmware Updater Configuration:

  1. Flash Method AVR Programmer Type
    tried "arduino" but errors saying "avrdude out of sync"
    changed to "wiring"
  2. Changed "avrdude Baud Rate" to 115200 (250000 same error as in 1. above)

These are not made clear in the OctoPrint-FirmwareUpdater/avrdude.md at da97332eb1fecc41f3a0b21a92a8f088f3be9555 · OctoPrint/OctoPrint-FirmwareUpdater · GitHub file (wiring only shown in screen shot and easily missed - arduino seems the obvious choice).

When using "Pronterface" I connect using 250000 so a bit confused here?

This "Octoprin"t Plugin is a "god send" and beats my earlier fix option of switching the USB cable from the "Pi to RAMPS board to the "Pi to my Desktop PC" to use VSC to compile the .hex file and using "avrdude" via SSH.

Thanks again.