Upload failed using Octoprint

What is the problem?

I'm connected to the Octopi. I can control the printer with Octoprint (movements, heating, webcam, etc) but when I try to upload a gcode file, I get this message:

Upload failed

Could not upload the file. Make sure that it is a readable, valid file with one of these extensions: .g, .gco, .gcode

I'm a total newbie, I am attempting to upload gcodes that were sliced in Cura. I don't know where to start to solve. Any help would be appreciated.

What did you already try to solve it?

Searched Google and this forum, couldn't find a solution.

Have you tried running in safe mode?

Running in safe mode made no difference.

Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.107 Safari/537.36 Edg/92.0.902.55
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 915718144
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Marlin bugfix-2.0.x (Jul 17 2021 18:06:12)
systeminfo.generator: systemapi


Additional information about your setup

OctoPrint version 1.6.1, OctoPi version 0.18.0, printer Anycubic Vyper, firmware ?, browser Windows Edge, operating system Windows 10,


Have you tried disabling browser extensions/running in InPrivate mode on the browser, sometimes we have seen that some of the extensions can conflict.

Also, the actual systeminfo bundle would be good as it contains the log files.

octoprint-systeminfo-20210804183934.zip (23.1 KB)

I'll try disabling browser extensions. Does Octoprint work better in Chrome or some other browser?

InPrivate and disabling extensions didn't work. Also tried Chrome, no luck.

Getting somewhere, from my laptop, it works fine. From my desktop it still doesn't work. I'm thinking a firewall issue or something?

Must have been my firewall. It's working now. Will use a different one


Sometimes it's a specific file name that triggers things, we have seen that in the past.

Thereโ€™s a neat plugin available in the Marketplace that will let you send the gcode directly to OctoPrint from Cura, without saving the gcode file first.