Upload .gcode file but does not show in file list

I have recently installed OctoPrint and OctoEverywhere. I am able to successfully access OctoPrint using OctoEverywhere.

Today I tried to upload my first .gcode file to my Pulse XE printer using OctoPrint. I clicked on Upload and selected the file from my Windows files systems. The file seemed to upload without a problem; but, then does not show in the files list. If I try to upload again, I am told the file exists and I can either load the file under a new name or overwrite.

Why I am not seeing the file in the OctoPrint files list ?


Hello @dcooper000 !

Just to clarify: You tried to upload a gcode-file via OctoPrint to SD card of the printer?

Assuming you used the Upload to printer feature, this would take quite a long time. Almost the time the files takes to be printed. The reason is, that the file is sent to the printer line by line.

I clicked OctoPrint’s Upload button (not Upload to SD, which is disabled. When I log into my RasperryPI (using Putty), I see the uploaded gcode file in the .OctoPrint/uploads folder; but, the Octoprint’s file list remains empty.

There have been questions for logs in the template you have deleted. This may make it more easy to find what is going on.

What is the filename of the file you uploaded?

The file was created from Ultimaker Cura and is named CFFFP_Twisted_Vase_Basic.gcode. And I see the file in the .octoprint/uploads fold on my Raspberry Pi.

And you don't see it in OctoPrint's GUI?

Correct, not listed in the File List in the OctoPrint GUI

Can you upload the systeminfo bundle?

Hmmm, just logged in to OctoPrint for the first time today and NOW THE FILES I UPLOADED ARE ALL IN THE FILES LIST. I logged in at least 3 times yesterday after having uploaded the files and they were not in the list.

Does OctoPrint take a long time to process the files ?

Not usually, but we can't explain without the systeminfo bundle. It's also worth testing with safe mode.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.