USB Camera Has massive lag and little to no FPS

Hello, I have NexiGo N60 USB Computer Camera hooked up to my raspberry pi 3B+. If I put the resolution anything about 480p the camera feed updates once in like a few minutes. I know this is a 1080 camera and I currently have it at 480p and 20 fps but it still barely updates the feed. I don't think it is working properly.

What did you already try to solve it?

Tried different resolutions and fps but it only really updates feed on the lowest resolution

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (1.7 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 Pro
Version 1.7.0
Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
Marlin V1.3.1

anything helps!

There are issues with the ABL expert and TheSpaghettyDedective.

Please try again in safe mode and share a new systeminfo bundle with that run.

And please don't power cycle the Pi. Sooner or later you will have a corrupted file structure on the SD card.

If you are using TSD premium, note that it will override the usual streaming settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.