USB Camera issues

Camera model


What is the problem?

I was using a Logitech webcam, unplugged it, plugged in the new camera rebooted server, and couldn't connect to the new camera.

What did you already try to solve it?

Plugged it into different USB ports, tried changing settings in Octoprint under Webcam / Timelapse, and Classic Webcam.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No (358.3 KB)

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version 1.9.3, OctoPi version 1.0.0cam, Ender 3 S1 Pro, Thomas Toka Marlin firmware V22, Google Chrome version 120.0.6099.130 (64 bit) , Windows 11 22H2 22621.2861,

Your log only displays a stream on the loopback

Did you add the


To your camera .conf file?
This has to be done by hand.

1 Like

Thank you for the reply. I went into /boot/camera-streamer/ and edited libcamera.conf, and added OPTIONS=--http-listen= to it.
I am currently printing, so once done I will reboot and see if it fixes it.
I appreciate your time.

Thank you! That seemed to fix the issue! I really appreciate your help.

I have the same camera DV 20 USB but shows horizontal mirror image.
How can I correct this ,?
Please advise.

Hello @BlueFish_Addicted !

Have you had already a deeper look onto the bundled OctoPrint plugins?

Hint: Classic Webcam