USB camera not being recognized at all in lsusb

Camera model
Creative Live! Cam Chat HD (model VF0790)

What is the problem?
My first time setting up OctoPrint using OctoPi. Tried to get the timelapse feature going and tried the advice on the setup page.
Camera is not even recognized by lsusb.

What did you already try to solve it?
Tried all 3 available USB ports. The camera LED doesn't even turn on.
Tried connecting the camera to my Win10 machine and the LED light came up, camera was recognized and automatically installed, then LED turned off.
Connected back to the Pi, tried go to through dmesg and find all the usb lines, and find out all the vendor IDs and device IDs.
The camera was not listed in dmesg, nor was the vendor.

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Ver: 1.3.12
OctoPi version 0.17.0
RasbPi B (rev 1.2)

Thank you!

Hello @Yoav_Farkash!

Have you tried to restart the RPi with the camera hooked on?

1 Like

Hi @Yoav_Farkash

If you can't see the device in dmesg or in lsusb something strange is happening!

Can you verify if the camera is working on other computer and if the PI power supply and the cable are providing the right voltage?

I've experienced similar problem with a poor usb cable used to power up the PI.


1 Like

Yes, tried both to plug it while it's working as well as restart with it plugged in.

That was it!
Tried connecting to my other RPi and it worked, found it in lsusb.
Changed the power supply on my OctoPi to the one from the 2nd RPi and it works.
I guess I need another power supply. Annoying, since I'm using the one that came with it...


1 Like