USB serial stopped working between Octoprint and my Prusa

What is the problem

I have a Prusa MK3S+ that had been working well for over a year. I have an RPi3 + OctoPi running for several hundred hours of printing with 0 issues.

After one particular failed print, we had to do an emergency stop, and ever since, Octoprint fails to negotiate serial, or more correctly it fails to get a response from the Prusa controller board, but I can't figure out why.

I'm still able to print via SD card and the control circuit still "initializes" with an LCD screen restart whenever I try to connect serial from Octoprint.

What did you already try to solve it?

  • I've tried multiple power supplies, thinking there was a voltage sag causing serial problems -> no help
  • I loaded the OctoPi package on a different (model) raspberryPi -> Same problem persisted
  • tried upgrading the firmware to the latest on the printer via laptop -> worked but Didn't help
  • tried downgrading firmware back to the last known functional version via laptop -> worked but didn't help.
  • Loaded octoprint on the (same) M1 macbook and tried running the serial connection there.

Have you tried running in safe mode?

I've tried safe mode.

Did running in safe mode solve the problem?

The serial behavior is the same in safe mode. (112.2 KB)

Systeminfo Bundle

Sysinfo attached.

Additional information about your setup

  • RPi 3B
  • Prusa MK3S+
  • OctoPrint 1.9.2
  • Python 3.7.3
  • OctoPi* 0.18.0 (build 2022.10.18.093204

dmesg output on Rpi for Prusa serial connection:
[15361.736068] usb 1-1.4: new full-speed USB device number 4 using dwc_otg
[15361.883114] usb 1-1.4: New USB device found, idVendor=2c99, idProduct=0002, bcdDevice= 1.30
[15361.883141] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[15361.883157] usb 1-1.4: Product: Original Prusa i3 MK3
[15361.883172] usb 1-1.4: Manufacturer: Prusa Research (
[15361.883187] usb 1-1.4: SerialNumber: CZPX3522X004XK81675
[15361.936305] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
[15361.937334] usbcore: registered new interface driver cdc_acm
[15361.937350] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

Terminal output on attemption connect:
Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyACM0, baudrate 19200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x7075e770, open=True>(port='/dev/ttyACM0', baudrate=19200, bytesize=8, parity='N', stopbits=1, timeout=5.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Thanks in advance.

try 115200 or 250000 as baudrate

1 Like

I assume that the Prusa "RPi Port" setting is "OFF", have you tried setting Octoprint connection device and baudrate to "AUTO", if so what do you see in the log?
Have you tried another USB cable and another USB port on the RPi I know it looks like the cable is OK because the printer.

@GordonW-Printer, thanks. I had completely forgotten there's an option in the LCD menu for the serial mode...and I guess when my son jammed things up and we had to factory-default the printer, it went back to "RPi" mode.

I switched it, power cycled everything, set all the serial options to "AUTO" and it was able to come back up and re-negotiate.

Thanks for the help. It always helps to have a second set of brain cells :slight_smile: