USB Webcam Setup on Jetson Nano 4GB

What is the problem?

Setting up and enabling usb webcam. I have a problem here "sudo apt install subversion libjpeg62-turbo-dev imagemagick ffmpeg libv4l-dev cmake" it comes up with "E: unable to locate package libjpeg62-turbo-dev". And when I tried make it failed. Sorry for not explaining better, I'm new to Linux. I'm very well versed in windows.

What did you already try to solve it?

I've gone through multiple guides now. The first one I used I was able to get the stream from the camera but everything with octoprint was pretty broken. I've followed the great guide on here on how to install
octoprint on a pi running Debian. I'm receiving errors at the point of enabling the webcam. Octoprint works perfectly.

Systeminfo Bundle (6.3 KB)

I'm pretty new to Linux, I've had good luck installing everything with zero issues but every install I've attempted from different guides I run into issues getting the webcam going.

Side note: I'm trying to install this on a nvidia jetson nano 4gb. Using the image provided from nvidia (L4T)

Also, if anyone wants to trade a pi4 for this Jetson message me. It's yours. I'll even throw in cash. Done with this pos.

Or if someone can put together an octopi like image for the Jetson that will just work, I'll happily pay.

I've been trying to figure out what underlying Linux distro is running on the jetson nano download... I think I've managed to work out it is based on Ubuntu 18.04/Linux kernel 4.9.

Try sudo apt install subversion libjpeg8-dev imagemagick libav-tools libv4l-dev cmake to see if that works, installing libjpeg8-dev instead of libjpeg62-turbo-dev. Not completely sure if it will work or not.

Alternatively you might be able to use another device as a webcam, such as an old smartphone, if it is too tricky to build a streamer on the Jetson Nano. Just another option.

Thank you, I should have replied here earlier. I somehow figured out I needed to do that. I am now successfully running octoprint, klipper, and all the good stuff on my jetson. I'm pretty proud considering I've never touched linux or a command line really. Only took me 38 hours over 4 days but it's done! God I'm happy now. Not sure if I can close this thread or if I need someone else to but all is solved.

1 Like

I tried that, it said this (in bold)

Reading package lists... Done
Building dependency tree **
Reading state information... Done
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
** ffmpeg:i386 ffmpeg

E: Package 'libav-tools' has no installation candidate

Are you using the same Ubuntu 18.04 distro?

(Same account as Liam_Snyder)

Oh! I'm on Ubuntu 20.04.3 LTS. What should I do for that?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.