USB webcam stream not working in Windows 10 install

What is the problem?

I just installed Octoprint on a Windows 10 Laptop PC. I also installed a USB webcam to use as the streaming device. And I installed Yawcam as the video streaming service.

The issue is that I can't get the stream URL to work. The timelapse URL works fine.

I use for the stream. If I click "test" it returns a broken link indicator.

However the same link works in the browser on both the local machine running octoprint and on a remote machine on the same network accessing octoprint.

Even if I go to the control tab of octoprint in the box that should contain the stream it says "webcam stream not loaded" and gives the link that is currently configured in the settings ( If I click the link the stream opens just as it should.

What did you already try to solve it?

I've tried different variations of the link adding "/" & "/video.mjpg" to the end. I even used the built-in laptop webcam and got the same results.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (6.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Windows 10 using Chrome browser on both octoprint host machine and the remote PC (on the same home network).

Brand new install of Octoprint yesterday.

No printer yet but it should be here in a day or two (Ender 3 S1 Pro) and I jut wanted to make sure everything will be ready when it arrives.

Any suggestions would be appreciated.

Thanks in advance!

1 Like

OK, so I fixed it myself.

I needed to change the yawcam stream setting from javascript to mjpeg.

once I did that I used the recommended setting ( and it worked.

1 Like

I want to record my screen for stream content but my USB webcam steam is not responding.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.