USB webcam wont function after board change

Pro Web Camera (garden verity)

**I had a hardware problem on my CR-10. The USB connector broke loose from the main PC board in the printer and damaged some traces. The printer still functioned with a SD card mounted directly into the printer, but obviously it could not function the the Raspberry Pi because it could not be connected without a USB cable. I replaced the main board in the printer with an upgrade (CR-10S board) and the printer functioned perfectly except I could no longer receive a video image from the Raspberry Pi. **

What did you already try to solve it?
I tested the camera on my computer (worked perfectly). I tried connecting other USB webcams (no luck). I tried rewriting the program on the Raspberry Pi SD card (no luck). I have put in the command string "sudo apt-get install fswebcam".** I have changed the SD card in the Raspberry Pi several times. I have searched solutions for this problem on the internet. The message i get when I click on the CONTROL tab on Octoprint then click on the " webcam/?action=stream" is only general instructions that doesn't lead me to a solution. From what I can surmise is that the video steam is either not being send out or it is not compatible with something.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
No entries are found in the log.

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctliPi id model 3B. Octoprint is latest version available. (reloaded several times)

You may try instead of webcam/?action=stream


Even that has a version number, and OctoPi too.

You can get that here:

This URL would not work, and if it was meant to be then that would only work to be accessed on the Pi. For the stream URL you need an external URL, the only one of those (out of the box) that works is http://<pi IP>/webcam/?action=stream. Accessing port 8080 is blocked out of the box.