User Login Problem

I created a new user and assigned a password. All worked fine with putty and SSH. I tried to log in directly at the pi and keep getting login failed.

auth.log doesn't give much help
May 27 04:35:22 octopi login[25739]: FAILED LOGIN (1) on '/dev/tty1' FOR '***', Authentication failure

I know the user ID and password are correct. Another thing I noticed is when I SSh in with the new user, the command prompt is just $ without the user:system I am used to seeing.
Maybe something was removed from the /etc/skel directory to save space, but not sure what.

root@octopi:/etc/skel# ls -lap
total 20
drwxr-xr-x 2 root root 4096 Nov 13 2018 ./
drwxr-xr-x 91 root root 4096 May 26 23:25 ../
-rw-r--r-- 1 root root 220 May 15 2017 .bash_logout
-rw-r--r-- 1 root root 3523 Nov 13 2018 .bashrc
-rw-r--r-- 1 root root 675 May 15 2017 .profile

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.9 (stretch)
Release: 9.9
Codename: stretch
OctoPrint version : 1.3.11
OctoPi version : 0.16.0

This is a fresh install on a new pi, using image, replacing an older model and haven't put this one into service yet.

Pretty sure it is something simple, but after 3 days of searching google and trying different things I am a bit frustrated.

so you're doing ssh user@ip, type in the password, and you end up at a $ prompt?

Share the output of "grep user /etc/passwd" (where "user" is your created username) please. You can also do ls -al /home/user/ to see if anything is weird there, but it seems like there's some shenanigans before that point.

Using a windows laptop and putty it workds fine. Using keyboard attached to the pi I get authentication failure. Default user works fine in both places,

pi@octopi:~ $ grep edf /etc/passwd

pi@octopi:~ $ ls -al /home/edf/
total 20
drwxr-xr-x 2 edf edf 4096 May 26 02:56 .
drwxr-xr-x 4 root root 4096 May 26 02:56 ..
-rw-r--r-- 1 edf edf 220 May 15 2017 .bash_logout
-rw-r--r-- 1 edf edf 3523 Nov 13 2018 .bashrc
-rw-r--r-- 1 edf edf 675 May 27 01:46 .profile

I flashed new cards twice thinking I did something weird, but end up with the same results every time.

The Pi by default ships with GB keyboard layout. For someone like me who is used to a DE layout that can usually mean a difference between "raspberry" and "raspberrz" being entered as the password. Make sure you enter the password as if you were using a GB keyboard - or change the default keyboard layout via raspi-config.

1 Like

Knew it was something simple. Wish I had asked here 3 days ago. Thanks for that.
I normally go thru the setup and change it on a new software load, never occured to me to check it on a prebuilt image.

Major problem fixed. Now to work out the minor stuff.