Using WiFi of PC over LAN not working

What is the problem?
I use the Wifi of a camera on the Pi so i have to connect it via LAN to the Internet.
My Router is very far away so i wanted to try connecting it via a LAN Cable Form the PC sharing its WiFi Connection trough that cable.
If i just mark the settings "allow other users using this Connection..." I can connect to the Pi with the octopi.local which is nice. But i normally used my routers VNP for connectivity Outsided of My Home, but now the pi isn't listed as a device in the Router settings so i cant create a vpn. Also i cant even Monitor it with my Smartphone anymore even if Smartphone and PC are on the Same WiFi, octopi.local has No Connection on the Phone. Atleast i don't know how to do it.

Is there a way to get it still showing up at the Router? Or do i have to Open an vpn for a specific Port of the PC Connection? I really dont know much of Internet settings and english isnt my Main language aswell, so i might need Help understanding :sweat_smile:

What did you already try to solve it?

I tried bridging but trying to Connect to octopi.local resulted in a bluescreen.

Then i Allowed Other devices using my wifi Connection in the settings.

In cmd i let it Show me the IP Adresses with ipconfig /all but trying top Connect to the given IP of the Pi wasnt possible.

Raspberry pi4
Fritzbox 7390
PC motherboard Asus strix gaming b450i
Windows 10 Home on PC and Octoprint on the Pi

I there a reason why you can't just connect the wifi cam to your home network?

Did you try it with just octopi or the ip address?

Its Not a WiFi Cam but a DSLR. But the Problem is that it has a ptp read only, so gphoto doesnt Work. The Other solution is to use its WiFi function since it doesnt have a headphonejack For a remote.

I Tried bridging by connecting the Raspberry Pi 4 with an Ethernet cable to the PC that ist connected to the WiFi. Then in the networksettings of the PC i selected both, the Ethernet and the WiFi Connection, right clicked and selected "Bridge Connection" (If thats the Term in English).
After that i tried top Connect via "octopi.local" and that resulted in a bluescreen as i said. While bridging the Connection i only got an ipv6 ip listed in ipconfig /all.
I only got a ipv4 adress by allowing Access to use the Internet Connection of the PC by Other devices. Trying even got a Ping Back From it, but trying to connect to the IP didnt Work. Only with octopi.local.

But it didnt Seen to be in my network actually, because the Pi couldnt controll the smart Plug that is Turning on my printer.... Do i have to enable lan Connection on the pi? And how do i do that? I thought i Just have to enable the Connection Sharing on my Windows pc

long time ago on closed networks we used hamachi i think for tunneling - try that it might work.
try ifconfig on PI and from your home PC connect via IP which show`s there.