V1.3 camera not working


Pi Cam 1.3

Red light is on but no image

Reinstalled Octprint multiple times, tried changing resolution, tried adding -y, changed to 128 mem split, enable in raspi-config

Webcam log doesnt exist
Octoprint version 1.4
Octopi Version 0.17.0
Pi 3B+
pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=1

pi@octopi:~ $ sudo apt-get install autoconf gettext libtool libjpeg62-dev
[sudo] password for pi:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libjpeg62-dev : Depends: libjpeg62 (= 1:6b2-2)
E: Unable to correct problems, you have held broken packages.

Just to be sure - here my picam checklist

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?

Did the camera work before?

yes if it wasnt the red light wouldnt be on and no its brand new never worked
Old usb cams work

You might consider installing what it's looking for:

sudo apt-get install libjpeg62

Or maybe:

mkdir ~/tmp
cd ~/tmp
git clone https://github.com/LuaDist/libjpeg.git
cd libj*
make install
cd ~
rm -Rf ~/tmp

sudo apt-get install libjpeg62
sudo reboot

double checked cam was turned on in raspi-config
double checked mem set to 128
sudo reboot

pi@octopi:~ $ vcgencmd get_camera

supported=1 detected=1

pi@octopi:~ $ raspistill -o cam.jpg
Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

Ran apt-get update && upgrade and rpi-update still just freezes the Pi during camera

Duff camera? I had this about a week ago. Swapped the camera with one I was using on another project and it worked straight away.

I gave up, Ill just get a USB Camera and be done with it, spent to much wasted time on something that should work.