V2 Camera Webcam Stream Not loaded


#1

What is the problem?

I'm trying to get my Raspberry Pi V2 camera working but on the control tab on octoprint, I get the 'Webcam Steam Not Loaded' message and I'm struggling to resolve the issue.

What did you already try to solve it?

I first tried different stream urls but nothing worked. I have triple checked my cable and even tried two different cables now, they are correctly orientated and everything is connected properly.

I've run

sudo apt-get update
sudo apt-get upgrade

and

sudo raspi-config

to make sure the camera is enabled. I've then tried

raspistill -v -o test.jpg

but it gives me the following:

"raspistill" Camera App (commit 7cbfbd38d982 Tainted)

Camera Name imx219
Width 3280, Height 2464, filename test.jpg
Using camera 0, sensor mode 0

GPS output Disabled

Quality 85, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Time delay 5000, Timelapse 0
Link to latest frame enabled no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Flicker Avoid Mode 'off'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Looking up the ENOSPC I have tried increasing the gpu_mem from 128 to 144 and replaced the /boot/cmdline.txt:

dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait bcm2708.w1_gpio_pin=18

Lastly, I've run octoprint in safemode and still no luck. Worth noting, this is all very new to me. I wouldn't be suprised if I've missed something simple but have been carefull to follow instructions and have double checked everything I can think of now.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Prusa i3 MK3
Latest firmware

OctoPrint version : 1.3.10
OctoPi version : 0.15.1

Running over Wifi, everything else works fine (printing, etc)

lsusb:

Bus 001 Device 004: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

vcgencmd get camera:

supported=1 detected=1

/var/log/webcamd.log:

<13>Feb 2 11:22:57 pi: Starting Raspberry Pi camera
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -fps 10
MJPG Streamer Version: git rev: 821c330ea6bbb5fbed98d48e00aac156e923161b
i: fps.............: 10
i: resolution........: 640 x 480
i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
o: www-folder-path......: ./www-octopi/
o: HTTP TCP port........: 8080
o: HTTP Listen Address..: (null)
o: username:password....: disabled
o: commands.............: disabled
i: Starting Camera
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
camera couldn't be enabled

Please let me know if there's any more info that might help! Thanks


#2

Hi Sam,

please have a look at this website:


it's in German, but in short it states that the connector between camera and board of the cam module is "open". Maybe it solves your problem, too?


#3

Hi THHL,

Thanks for the suggestion. Sadly, I've checked this now and it was plugged in. I have tried unplugging the camera and plugging it back in (whilst everything was off of course!) but no luck yet!


#4

For whatever reason raspistill stopped working within the last year.

Rule out things like OctoPrint's-webcam-tag-doesn't-work-on-Internet-Explorer. Go straight to the webcam URL: http://octopi.local:8080/ and exercise some of the links there like http://octopi.local:8080/?action=stream .

When Raspbian drivers don't work, the next thing to consider would be upgrading the Raspbian firmware:

sudo apt-get update
sudo apt-get -y upgrade
# Brew some tea

#5

Those url's don't work for me. I've tried replacing octopi.local with the IP too with no success. I tried them on Chrome, Edge and IE to be sure it wasn't a browser issue.

I've also fully upgraded the raspbian firmware as you've suggested. Again, sadly no luck!


#6

I'm having the exact same issues as you Samwise - I'm pulling my hair out here. I've followed all the same steps as you including the obvious ones regarding the correct orientation of the cable and it's seated correctly (including the connector on the camera board), ensuring there is enough power to the Pi B+. Just getting the same ENOSPC error. Hopefully, someone can help!


#7

I have two of these cameras and I rarely have problems with them. I've used Jessie and Stretch versions of Raspbian and a year's worth of OctoPi-imaged microSDs with them as well as a stand-alone install just for the webcam. I'm now coding against another rig with one.

  • Throughout all of that, I've never edited the cmdline.txt as you've done. Perhaps you need to reverse that to the default.
  • The cmdline.txt needs an entry start_x=1 and gpu_mem=128 (or higher). This is what the raspi-config enabling does, btw. It should load up the elf file which includes camera support. I'm guessing that this is working on yours but it's worth checking.
  • Here's a step-by-step tutorial that I did for the Robo C2 printer but it's reasonably pertinent except for that raspistill suggestion. Ignore the part in the instructions where you "Turn on Video" in the OctoPrint interface; that's Robo-specific. Ignore the bit about rotation of the image.
  • Likewise, here's another tutorial which I wrote for a stand-alone webcam for OctoPrint use. You might consider just moving the cam to another Pi and hosting the images from there, per the instructions.

#8

Ok, I've given those tutorials a go this morning. I've even started clean and re-imaged the micro sd card and followed all the steps. Still no success :face_with_raised_eyebrow:

I've found this post over on raspberry pi:

How might I go about trying an older version of raspbian as this post suggests?

I had the same problem. I tried an older version of Raspbian 4.9.59 Nov 2017 and the camera worked. I then reflashed the SD card with the June 2018 download. I skipped the request to update when the Pi booted up. I'm running Raspbian 4.14.50-v7+ #1122 and the camera works now. When you update it, you get 41.14.62-v7+ #1134 so don't update. It has a bug.

I'd like to try that before I try replacing the camera as another post mentions that fixed it for them. (I've come across plenty of other posts saying replacing the cam didn't help too...)


#9

I've heard some suggest that replacing the camera magically made everything work. I've heard some suggest that replacing the Raspberry Pi 3B magically worked.

I'm one of those crazy people who have lots of Pi's, ribbon cables and webcams. In a case like this I'd start swapping hardware and follow where the error goes.

You could chase an old copy of Raspbian but then you'd need to install OctoPrint. Instead, I'd chase an old OctoPi image that happens to have the target older version of Raspbian and then upgrade OctoPrint which seems easier to me. (Unless of course, you're going the dedicated webcam route as I suggested before.)

  • Dedicated webcam server route: Archive
  • Use the wayback machine on OctoPi: Archive

#10

Unfortunately, this is my first pi so I don't have hardware to start swapping.

The good news is I have just got a cheap Rev1.3 camera off amazon and given it a try and it seems to be working just fine. Mildly frustrating to have gone through so much to find its most likely a hardware issue but glad to have something working now.

I will see about returning the V2.1 model as it seems likely to be at fault now and see if they'd replace it or not. I'll update if I manage to get another V2.1 to confirm that was the problem and there isn't a larger issue between the 3B+ and the V2.1 cam.

To note, I have reversed the cmdline.txt (fresh image on the SD) as you'd suggested @OutsourcedGuru, and I followed your step-by-step tutorial in setting up the pi after. Thank you for all the help! Very much appreciated.

@vortex_uk, you could maybe also try swapping the camera out. I got one for £7.99 on amazon. Hope you get yours working too!


#11

Thanks @Samwise I'll give that a shot - glad it's working for you. I've just ordered the same £7.99 rev1.3 off Amazon so fingers crossed.