Vcgencmd error when updating Pi Support Plugin 2021.10.28 ➡ 2022.3.1

What is the problem?

What did you already try to solve it?

pi@octopi2021:~ $ groups pi
pi : pi adm tty dialout cdrom sudo audio video plugdev games users input netdev spi i2c gpio

Have you tried running in safe mode?

Not yet.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3971153920
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.0.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.7.3
printer.firmware: Marlin TH3D UFW 2.38 (Feb 3 2022 21:58:07)
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

2022-03-02 15:29:11,263 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2022-03-02 15:31:17,449 - octoprint.plugins.softwareupdate - INFO - Starting update of pi_support to 2022.3.1...
2022-03-02 15:31:21,427 - octoprint.plugins.softwareupdate - ERROR - Update of pi_support can not be performed, please also check plugin_softwareupdate_console.log for possible causes of this
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/softwareupdate/", line 2090, in _perform_update
target, populated_check, target_version, log_cb=self._log, online=online
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/softwareupdate/updaters/", line 115, in perform_update
returncode, stdout, stderr = pip_caller.execute(*pip_args, **pip_kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 208, in execute
return, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 244, in call
all_stdout += process_stdout(p.stdout.readlines(timeout=0.5))
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 236, in process_stdout
return process_lines(lines, self._log_stdout)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 230, in process_lines
*map(lambda x: to_unicode(x, errors="replace"), lines)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 498, in _preprocess_lines
return list(map(self._preprocess, lines))
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 517, in _preprocess
return to_unicode(clean_ansi(text))
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 57, in clean_ansi
return _ANSI_REGEX.sub(b"", line.encode("latin1")).decode("latin1")
UnicodeEncodeError: 'latin-1' codec can't encode characters in position 5-44: ordinal not in range(256)
2022-03-02 15:31:21,492 - octoprint.plugins.softwareupdate - INFO - Saved update log to disk
2022-03-02 15:33:27,731 - octoprint.plugins.pluginmanager - INFO - Loaded plugin repository data from
2022-03-02 15:33:28,810 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-isp-capture0 based on ^bcm2835-isp-\w+ 2022-03-02 15:33:28,812 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-codec-isp based on ^bcm2835-codec-\w+
2022-03-02 15:33:28,843 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-codec-decode based on ^bcm2835-codec-\w+ 2022-03-02 15:33:28,845 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-isp-capture1 based on ^bcm2835-isp-\w+
2022-03-02 15:33:28,847 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-isp-output0 based on ^bcm2835-isp-\w+ 2022-03-02 15:33:28,848 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-codec-encode based on ^bcm2835-codec-\w+
2022-03-02 15:33:28,881 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-codec-image_fx based on ^bcm2835-codec-\w+ 2022-03-02 15:33:28,883 - octoprint.plugins.camerasettings - INFO - Excluding camera bcm2835-isp-stats2 based on ^bcm2835-isp-\w+
2022-03-02 15:38:41,238 - octoprint.server.util.sockjs - INFO - Client connection closed: ::ffff:

2022-03-02 15:31:17,454 /home/pi/oprint/bin/python3 -m pip --disable-pip-version-check install --no-cache-dir

2022-03-02 15:31:21 - Pi Support Plugin - 2021.10.28 -> 2022.3.1 - FAILED - Update failed (Release notes: Release 2022.3.1 · OctoPrint/OctoPrint-PiSupport · GitHub) (68.6 KB)

Well this appears to be fixed by simply rebooting the pi! ¯_(ツ)_/¯

This updating issue is a known issue with the latest pip (22.0.3) and OctoPrint - it's been fixed for 1.8.0 which should be in release candidates soon.

1 Like

I got the same error with every plugin it tried to install from my backup. But I could install them from the plugin manager without error... Not sure what the difference would have been as they are using the same pip

It doesn't happen every time you try and install something. The issue is related to a new progress bar that pip added to the stdout when it is downloading something. When you went to install from the plugin manager I suspect it used any cached dependencies from when it tried to install before.

1 Like

Ah! That makes sense, before I restarted my pi I SSH'd in and manually updated things.

Not fixed in 1.8.0 rc2

The original problem definitely has, we've had several confirmations of it. As it says on the RC release notes.... If you have a problem please open a bug report, a single comment here doesn't help track the issue down.

I can't find any reference to vcgencmd in the release notes for either rc1 or rc2

OK but you replied to my comment that was specifically about the update issue being fixed in 1.8.0, nothing else:

The vcgencmd error is completely different, for the OP just reboot fixed it - there's nothing that can be fixed from OctoPrint's end, it's something on your install if it can't use vcgencmd properly.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.