Video of webcam not working

I just enabled Octoprint and connecte a Logitech C905 to the USB port.
When I am now into OctoPrint Settings > Webcam, I am getting connected to the cam only partly.
I set Snapshot-URL to: http://{raspberryPi IP-address}:8080/?action=snapshot
When clicking test-button a snapshot si being show.
But I cannot see any Stream, when hitting test button (Stream-URL: http://{raspberryPi IP-address}/webcam/?action=stream )
The popup is just showing the text information, that a stream should be visible.
What is wrong? Can anybody help?

Try to add port 8080 to the webcam stream url :slight_smile:

I now tested with another webcam (Creative Live Cam Sync):

Snapshots are shown, when clicking Test-button (Snapshot-URL:

Using Stream-URL = by clicking Test-button is showing:

Port 8080:

Using default (/webcam/?action=stream) is different:

Requesting the webcam stream via separate browser (http://{IP of Raspberry}/webcam/?action=stream):

(in browser tab title is shown: webcam (640x480)

Using URL http://{IP of Raspberry}:8080/webcam/?action=stream in a separate browser is showing an error:
400: Not Found!
No file extension found

Any idea? How can I get the full video and not only the upper area?
Is there a way to configure the cam (like resolution, so not only 640x480)?

One remark: I have no 3d-printer connected to USB yet.

Thanks for your help. does only work on the device itself.
Yeah stay without the 8080 part

How is the pi connected to your network?
The partly shown picture might be the result of poor wifi signal strength.

To edit the webcam settings open the octopi.txt file on the boot partition of your sd card.

I am already trying to edit octopi.txt via WinSCP, but I have no permissions.
Then I tried to change permissions via sudo chmod 777 octopi.txt but this isn't changing. How can I change permissions of this file, so I can edit it via network. I do not want to remove and insert the SDcard all the time.
Yes, I am using WiFi.

I was getting crazy, so I shut down Raspberry and removed SDcard to change octopi.txt.
I now enabled camera="auto" and added camera_usb_options="-r HD -f 5"
Now it is working :slight_smile:

But I am still interested in getting the permissions changed. How will that work?

Just edit it in ssh :slight_smile:
sudo nano /boot/octopi.txt

How to use nano?

How can permissions be adjusted?

The Internet is chock full of tutorials. It's one of the many ways I myself learn.

QI will have a look.

After my adjustments I did - as described before- now I wonder about the stability. I have seen the snapshots and streaming. But after a while it isn’t working any more.
Why is it stopping suddenly?

It is horrible!
Now I can still see screenshots, but no video-stream any more.
Why is that so unstable? Is there a way to analyse?


I now found out something crazy:
When requesting the stream via IP address (http://{IP of Raspberry}/webcam/?action=stream) it isn’t working. But using octopi.local instead helps: http://octopi.local/webcam/?action=stream
What’s that?

Maybe you're using the wrong ip?

I copied the IP from the browser window showing Octoprint Settings panel. As I get at least a small part of the video, the IP cannot be wrong:

Using the name instead of IP (http://octopi.local/webcam/?action=stream instead of, I get the full video:

So what crazy implementation is that?

Maybe just go directly to the stream and bypass OctoPrint's endpoint.


Great, thanks.