Video Stream Lagging


#1

What is the problem?
After a few days after new image flash video stream start lagging. Here is link to stream: http://megatronix-11.com:2580/webcam/?action=stream

What did you already try to solve it?
I tried to change sdcards, flash different versions of octoprint.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Now I'm with 1.3.7rc4. My printer is DIY and firmware is Marlin 1.1.6.
octoprint.log:
octoprint.log (98.5 KB)


#2

webcamd.log:
webcamd.log (8.6 KB)


#3

Are you going thru WiFi or Ethernet to your Pi?
What flavor of Pi do you have?


#4

Hello. Thank you for your reply.

It is connected through ethernet and I'm using Pi 3+.


#5

If you lower your camera resolution, does the lag improve?


#6

No. When I flash new image I changed the resolution. It works perfect a few days and then it getting lagging. I tried all USB ports, change camera settings to default but it doesn't work. Only fix that I found is to flash new image but I should install all plugins and set all settings again and again.


#7

off topic

Different question what plugin alows you to show your pi's CPU temp? Thats quit cool... + Is the authentication actually "save" I never trusted it enough to forward it through the router


#8

Plugin name is: Room Temperature Plugin


#9

If you are saving the images, buffers could be full and lots of file operations are required to keep from crashing. See if the sd card is near full.