Viewing the octoprint video stream in a browser

Background information:
I have two BIBO2 printers, each with their own Pi. After a year of procrastinating, I finally decided to wire in the cam on my second BIBO printer. The first printer has a Pi3b with a cam running flawlessly. The second printer has a Pi4b also working fine but just haven't added the cam till now. Both on static (reserved) IPs whether they are wired or wireless. Both have Arducams (purchased at different times, but identical I think). Both printers print. I can access them both remotely and send print jobs, read and write to the uploads folder over the network, etc.

What is the problem?
Initially, I didn't have any problems. The stream works fine WITHIN Octoprint, so the cam is technically working. I even got the manual focus to work in the UI. The problem I'm having is that I cannot view the video stream from that printer/octopi using a web browser (separate from the Octoprint IU). The browser message is "The connection is refused". This is to connect locally (within my network), not from the Internet. My first BIBO printer has always allowed me to connect with no issues using the same method... and still does.

What did you already try to solve it?
Using my first Octopi that works fine as reference, I've tried comparing any and all settings I could think of. Both seem identical, but obviously I'm missing something. It's acting like there's a firewall blocking or port that isn't open. I'm still a little green to the linux OS so I don't know where else to look. Already tried other browsers (Chrome, Firefox, Edge, Opera), so it's not a browser issue. Also tried other machines and still get the same connection refused message. So, I think that effectively narrows it down to a missed setting or issue within octoprint.

Logs (syslog, dmesg, ... no logs, no support)
This doesn't appear to be an event that's logged, but maybe I missed something...
octoprint.log (181.1 KB) (105.7 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
This isn't an IP conflict or a general connection issue with Octoprint because both printers work perfectly otherwise... but if it helps, I have a 2016 production server running the network for both my home and business. It assigns and reserves IPs as needed. Most everything is wired throughout the house using two main 16 port switches. However I had to move them, so both OctoPi are currently on the wireless, which are connecting via APs all managed by my ZyXEL firewall. Signal strength for both Octopi hover around 90%. The Octopi in question appears to work perfect in every way EXCEPT for the inability to access the stream from the cam via a web browser.

So, on the instance that is not working for viewing outside OctoPrint (but is working inside OctoPrint), please share:

  • The address you use for accessing OctoPrint
  • The address you are trying to use to access the webcam
  • The configured 'stream URL' in OctoPrint's settings

That should get somewhere closer to finding the issue.

Thanks for the reply. The IP for that Octopi is So, the address I'd use to view the stream in any browser would be Your third item made me realize something. I remember (or thought I remembered) the stream URL being left at that IP address, but the only thing in the box currently is "/webcam/?action=stream". When I put the full address that I typed above and test or save it, then nothing works. Now I feel like it's probably something simple I missed somewhere, but I'm just not seeing it right now. Been staring at this for way too long :roll_eyes:. I appreciate any input you have.


Leave the stream URL as /webcam/?action=stream and to access the camera outside OctoPrint use

On OctoPi 0.18 the webcam is not accessible on port 8080 by default, only through the reverse proxy to /webcam/.